summaryrefslogtreecommitdiffstats
path: root/system/sunflower
diff options
context:
space:
mode:
author B. Watson2022-03-12 19:17:26 +0100
committer B. Watson2022-03-12 19:25:02 +0100
commit6a432164af70979edd747caeb8f0fa1262dd4a53 (patch)
treeb929ffa49d8b4fbd3ad5e4deac4deca56dbd60d0 /system/sunflower
parent326a8840b801e546dd0953f99e7a3379e4b3871a (diff)
downloadslackbuilds-6a432164af70979edd747caeb8f0fa1262dd4a53.tar.gz
system/sunflower: Fix VERSION in script.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/sunflower')
-rw-r--r--system/sunflower/sunflower.SlackBuild17
-rw-r--r--system/sunflower/sunflower.info2
2 files changed, 10 insertions, 9 deletions
diff --git a/system/sunflower/sunflower.SlackBuild b/system/sunflower/sunflower.SlackBuild
index e12ecbfb12..3368022b3b 100644
--- a/system/sunflower/sunflower.SlackBuild
+++ b/system/sunflower/sunflower.SlackBuild
@@ -21,11 +21,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220312 bkw: Modified by SlackBuilds.org: VERSION must be constant,
+# and match VERSION in the .info file. Also, do not install useless
+# INSTALL in documentation directory.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sunflower
-SRCVER=${SRCVER:-0.5-63}
-VERSION=${VERSION:-$(echo $SRCVER | sed 's/-/\./g')}
+VERSION=${VERSION:-0.5_63}
+SRCVER="$( echo $VERSION | tr _ - )"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +76,9 @@ cd Sunflower
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
@@ -96,7 +97,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp AUTHORS CHANGES COPYING INSTALL LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp AUTHORS CHANGES COPYING LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/sunflower/sunflower.info b/system/sunflower/sunflower.info
index 95f0dfc489..8433c9d41a 100644
--- a/system/sunflower/sunflower.info
+++ b/system/sunflower/sunflower.info
@@ -1,5 +1,5 @@
PRGNAM="sunflower"
-VERSION="0.5.63"
+VERSION="0.5_63"
HOMEPAGE="https://sunflower-fm.org"
DOWNLOAD="https://sunflower-fm.org/pub/sunflower-0.5-63.tgz"
MD5SUM="33c0bba1ccaf256838f5be12ddad5e7f"