summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo2022-06-04 05:42:50 +0200
committer Willy Sudiarto Raharjo2022-06-11 03:58:58 +0200
commit65d4245ddeec6c66df6119e4d6463bfbeec7ddd3 (patch)
tree5d4c5ec812ba52beb4510066b7511f141b2b7f52 /python
parentf0d4b2db1c40b8188c0780b995071d9c62fbbdb9 (diff)
downloadslackbuilds-65d4245ddeec6c66df6119e4d6463bfbeec7ddd3.tar.gz
python/python3-rebulk: Added (Advanced searches in strings)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-rebulk/README6
-rw-r--r--python/python3-rebulk/python3-rebulk.SlackBuild101
-rw-r--r--python/python3-rebulk/python3-rebulk.info10
-rw-r--r--python/python3-rebulk/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/python/python3-rebulk/README b/python/python3-rebulk/README
new file mode 100644
index 0000000000..a873680a54
--- /dev/null
+++ b/python/python3-rebulk/README
@@ -0,0 +1,6 @@
+ReBulk is a python library that performs advanced searches in strings
+that would be hard to implement using re module or String methods only.
+
+It includes some features like Patterns, Match, Rule that allows
+developers to build a custom and complex string matcher using a
+readable and extendable API.
diff --git a/python/python3-rebulk/python3-rebulk.SlackBuild b/python/python3-rebulk/python3-rebulk.SlackBuild
new file mode 100644
index 0000000000..15d9aadd19
--- /dev/null
+++ b/python/python3-rebulk/python3-rebulk.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/bash
+
+# Slackware build script for python3-rebulk
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20220603 46and2: remove unneeded requirement from setup.py
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-rebulk
+SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
+VERSION=${VERSION:-3.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#remove unneeded requirement
+sed -i 's/pytest-runner//' setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-rebulk/python3-rebulk.info b/python/python3-rebulk/python3-rebulk.info
new file mode 100644
index 0000000000..c459f1be05
--- /dev/null
+++ b/python/python3-rebulk/python3-rebulk.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-rebulk"
+VERSION="3.1.0"
+HOMEPAGE="https://github.com/Toilal/rebulk/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/r/rebulk/rebulk-3.1.0.tar.gz"
+MD5SUM="ce9e0f02e5e812859a479d6536543f41"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-rebulk/slack-desc b/python/python3-rebulk/slack-desc
new file mode 100644
index 0000000000..d09d601636
--- /dev/null
+++ b/python/python3-rebulk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-rebulk: python3-rebulk (Advanced searches in strings)
+python3-rebulk:
+python3-rebulk: ReBulk is a python library that performs advanced searches in strings
+python3-rebulk: that would be hard to implement using re module or String methods
+python3-rebulk: only. It includes some features like Patterns, Match, Rule that
+python3-rebulk: allows developers to build a custom and complex string matcher using
+python3-rebulk: a readable and extendable API.
+python3-rebulk:
+python3-rebulk: Homepage: https://github.com/Toilal/rebulk/
+python3-rebulk:
+python3-rebulk: