summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author isaackwy2024-02-26 05:42:54 +0100
committer Willy Sudiarto Raharjo2024-02-28 06:59:13 +0100
commit4e040f3afc9cc11d6de7e2c895051d50a4bba0b9 (patch)
treed248b35973027f3deab7697758b8c1f91bea9e3f /python
parent106d9440313cbe10a86775acab571e7ab920f8f8 (diff)
downloadslackbuilds-4e040f3afc9cc11d6de7e2c895051d50a4bba0b9.tar.gz
python/python3-sniffio: Update for 1.3.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-sniffio/python3-sniffio.SlackBuild28
-rw-r--r--python/python3-sniffio/python3-sniffio.info8
2 files changed, 11 insertions, 25 deletions
diff --git a/python/python3-sniffio/python3-sniffio.SlackBuild b/python/python3-sniffio/python3-sniffio.SlackBuild
index d00ace7b2e..e4f4311c45 100644
--- a/python/python3-sniffio/python3-sniffio.SlackBuild
+++ b/python/python3-sniffio/python3-sniffio.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-sniffio
-# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-sniffio
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,14 +64,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CODE_OF_CONDUCT.md CONTRIBUTING.md LICENSE* README.rst \
+ CODE_OF_CONDUCT.md CONTRIBUTING.md README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python3-sniffio/python3-sniffio.info b/python/python3-sniffio/python3-sniffio.info
index f98e685d54..7064cd61a3 100644
--- a/python/python3-sniffio/python3-sniffio.info
+++ b/python/python3-sniffio/python3-sniffio.info
@@ -1,10 +1,10 @@
PRGNAM="python3-sniffio"
-VERSION="1.3.0"
+VERSION="1.3.1"
HOMEPAGE="https://github.com/python-trio/sniffio"
-DOWNLOAD="https://github.com/python-trio/sniffio/archive/v1.3.0/sniffio-1.3.0.tar.gz"
-MD5SUM="09da8e81083e68527f206341b2c88932"
+DOWNLOAD="https://github.com/python-trio/sniffio/archive/v1.3.1/sniffio-1.3.1.tar.gz"
+MD5SUM="39144e000300307b45eb4560286089c2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-scm-opt"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"