summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis2024-02-14 17:01:43 +0100
committer Willy Sudiarto Raharjo2024-02-17 03:07:16 +0100
commit786439f3cd482353a39cdca9b354f9037beb49c8 (patch)
tree610282689a6b18d5b0931180bb5aeeb21863fa22 /network
parent5ef4209d012c98b8d46e6e55445f04c9235102f1 (diff)
downloadslackbuilds-786439f3cd482353a39cdca9b354f9037beb49c8.tar.gz
network/twine: Updated for version 5.0.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/twine/setup.py5
-rw-r--r--network/twine/twine.SlackBuild8
-rw-r--r--network/twine/twine.info6
3 files changed, 7 insertions, 12 deletions
diff --git a/network/twine/setup.py b/network/twine/setup.py
deleted file mode 100644
index 0ae4555937..0000000000
--- a/network/twine/setup.py
+++ /dev/null
@@ -1,5 +0,0 @@
-from setuptools import setup
-
-
-if __name__ == '__main__':
- setup()
diff --git a/network/twine/twine.SlackBuild b/network/twine/twine.SlackBuild
index d7eafaeb94..77ff78a50d 100644
--- a/network/twine/twine.SlackBuild
+++ b/network/twine/twine.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for twine
-# Copyright 2016-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=twine
-VERSION=${VERSION:-4.0.2}
+VERSION=${VERSION:-5.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,7 +71,6 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cp $CWD/setup.py $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -80,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/twine/twine.info b/network/twine/twine.info
index 21ecd1e105..129d42dbd5 100644
--- a/network/twine/twine.info
+++ b/network/twine/twine.info
@@ -1,8 +1,8 @@
PRGNAM="twine"
-VERSION="4.0.2"
+VERSION="5.0.0"
HOMEPAGE="https://github.com/pypa/twine"
-DOWNLOAD="https://files.pythonhosted.org/packages/b7/1a/a7884359429d801cd63c2c5512ad0a337a509994b0e42d9696d4778d71f6/twine-4.0.2.tar.gz"
-MD5SUM="f38ded461689ecb781d107e92ccb7eeb"
+DOWNLOAD="https://files.pythonhosted.org/packages/d3/cc/8025ad5102a5c754023092143b8b511e184ec087dfbfb357d7d88fb82bff/twine-5.0.0.tar.gz"
+MD5SUM="692f628c3708beca5f9073b0988e8f8f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pkginfo requests-toolbelt readme_renderer python3-keyring python-importlib_metadata python3-rfc3986 python3-rich"