summaryrefslogtreecommitdiffstats
path: root/libraries/wvstreams/wvstreams.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini2018-07-21 18:30:25 +0200
committer Matteo Bernardini2018-07-21 18:30:25 +0200
commitedc3e434486c95e7ee8e227def485cc9e068f377 (patch)
tree85312122d425cbf4fcc00475938a40451c4dc97c /libraries/wvstreams/wvstreams.SlackBuild
parentec1a4a932c386f509cf24092be7aa38837d57ddd (diff)
downloadslackbuilds-current-20180722.1.tar.gz
20180721.2 global branch merge.current-20180722.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/wvstreams/wvstreams.SlackBuild')
-rw-r--r--libraries/wvstreams/wvstreams.SlackBuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/libraries/wvstreams/wvstreams.SlackBuild b/libraries/wvstreams/wvstreams.SlackBuild
index 562bb05d11..fe600b62c9 100644
--- a/libraries/wvstreams/wvstreams.SlackBuild
+++ b/libraries/wvstreams/wvstreams.SlackBuild
@@ -59,13 +59,20 @@ patch -p1 < $CWD/patches/wvstreams-4.6.1-parallel-make.patch
patch -p1 < $CWD/patches/wvstreams-4.6.1-gcc47.patch
# another patch for gcc and glibc > 2.12.0 from debian
patch -p1 < $CWD/patches/05_gcc.diff
+# another one for gcc-6.x from fedora
+patch -p1 < $CWD/patches/0001-Use-explicit-cast-and-prevent-compiler-error.patch
+# disable a warning (just for readability during build)
+sed -i "s|_BSD_SOURCE|_DEFAULT_SOURCE|" wvrules.mk
+# Fix build against openssl
+patch -p1 < $CWD/patches/openssl-buildfix.patch
# configure doesn't support disabling static libraries
# Don't manually remove them either, as wvdial won't build then :)
# Added more flags to avoid aborting when building with gcc-4.7.x
# https://bugs.gentoo.org/show_bug.cgi?id=419971
+LIBS="-L/usr/lib${LIBDIRSUFFIX}/openssl-1.0" \
CFLAGS="$SLKCFLAGS -fno-tree-dce -fno-optimize-sibling-calls" \
-CXXFLAGS="$SLKCFLAGS -fno-tree-dce -fno-optimize-sibling-calls" \
+CXXFLAGS="$SLKCFLAGS -fno-tree-dce -fno-optimize-sibling-calls -I/usr/include/openssl-1.0" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \