summaryrefslogtreecommitdiffstats
path: root/libraries/libcec
diff options
context:
space:
mode:
author Jeremy Hansen2024-09-06 02:00:52 +0200
committer Willy Sudiarto Raharjo2024-09-06 04:44:46 +0200
commitdbd08a5208d6d4295a1dca78e7b1141f29e2d873 (patch)
tree46d270665327a7b8f55ffa2ff7e02fcfdf4dc6a5 /libraries/libcec
parent6479e72805689937f9a23ab14a211706e0c2f9fe (diff)
downloadslackbuilds-dbd08a5208d6d4295a1dca78e7b1141f29e2d873.tar.gz
libraries/libcec: New maintainer
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libcec')
-rw-r--r--libraries/libcec/libcec.SlackBuild20
-rw-r--r--libraries/libcec/libcec.info4
2 files changed, 13 insertions, 11 deletions
diff --git a/libraries/libcec/libcec.SlackBuild b/libraries/libcec/libcec.SlackBuild
index 5ba5ad724f..e20696effe 100644
--- a/libraries/libcec/libcec.SlackBuild
+++ b/libraries/libcec/libcec.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for libcec
# Copyright 2011-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -86,24 +84,28 @@ sed -i \
mkdir -p build
cd build
- cmake -G "Unix Makefiles" \
- -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
+ cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
- make VERBOSE=1
- make install DESTDIR=$PKG
-cd -
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
install -D -m 0644 debian/cec-client.1 $PKG/usr/man/man1/cec-client.1
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING README.md debian/changelog.in $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING README.md debian/changelog.in \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/libcec/libcec.info b/libraries/libcec/libcec.info
index b1b08d4473..991c513256 100644
--- a/libraries/libcec/libcec.info
+++ b/libraries/libcec/libcec.info
@@ -6,5 +6,5 @@ MD5SUM="68bb5aa90857fb5436795f2cfc163e0c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="platform"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"