summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author B. Watson2022-03-02 19:17:19 +0100
committer Willy Sudiarto Raharjo2022-03-03 09:56:42 +0100
commit1c30d5e0ebd1b91bad657e9d3aeacb797a6b7f37 (patch)
tree47a23ae7ce5e84cd345a7f1cba461440909c61e7 /graphics
parent5118983013062f543e1fa4908a22b420c57a62d9 (diff)
downloadslackbuilds-1c30d5e0ebd1b91bad657e9d3aeacb797a6b7f37.tar.gz
graphics/rawstudio: Removed (FTBFS).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/rawstudio/README2
-rw-r--r--graphics/rawstudio/doinst.sh4
-rw-r--r--graphics/rawstudio/patches/lensfun03.patch11
-rw-r--r--graphics/rawstudio/patches/libpng15.patch40
-rw-r--r--graphics/rawstudio/rawstudio.SlackBuild130
-rw-r--r--graphics/rawstudio/rawstudio.info10
-rw-r--r--graphics/rawstudio/slack-desc19
7 files changed, 0 insertions, 216 deletions
diff --git a/graphics/rawstudio/README b/graphics/rawstudio/README
deleted file mode 100644
index f9ff1fc345..0000000000
--- a/graphics/rawstudio/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Rawstudio is an open-source program to read and manipulate
-RAW images from most digital cameras.
diff --git a/graphics/rawstudio/doinst.sh b/graphics/rawstudio/doinst.sh
deleted file mode 100644
index 65fd352418..0000000000
--- a/graphics/rawstudio/doinst.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
-fi
-
diff --git a/graphics/rawstudio/patches/lensfun03.patch b/graphics/rawstudio/patches/lensfun03.patch
deleted file mode 100644
index ee2f3554e7..0000000000
--- a/graphics/rawstudio/patches/lensfun03.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/plugins/lensfun/lensfun.c
-+++ b/plugins/lensfun/lensfun.c
-@@ -668,7 +668,7 @@ get_image(RSFilter *filter, const RSFilterRequest *request)
- }
-
- /* Start threads to apply phase 2, Vignetting and CA Correction */
-- if (effective_flags & (LF_MODIFY_VIGNETTING | LF_MODIFY_CCI))
-+ if (effective_flags & LF_MODIFY_VIGNETTING)
- {
- /* Phase 2 is corrected inplace, so copy input first */
- guint y_offset, y_per_thread, threaded_h;
diff --git a/graphics/rawstudio/patches/libpng15.patch b/graphics/rawstudio/patches/libpng15.patch
deleted file mode 100644
index f83e82de85..0000000000
--- a/graphics/rawstudio/patches/libpng15.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -wbBur rawstudio-2.0/plugins/load-gdk/exiv2-colorspace.cpp rawstudio-2.0.my/plugins/load-gdk/exiv2-colorspace.cpp
---- rawstudio-2.0/plugins/load-gdk/exiv2-colorspace.cpp 2011-02-24 01:35:18.000000000 +0300
-+++ rawstudio-2.0.my/plugins/load-gdk/exiv2-colorspace.cpp 2012-01-23 15:03:22.000000000 +0400
-@@ -102,8 +102,8 @@
- {
- *linear_guess = FALSE;
- RSColorSpace* profile = NULL;
-- const gchar *icc_profile_title;
-- const gchar *icc_profile;
-+ png_charp icc_profile_title;
-+ png_bytep icc_profile;
- guint icc_profile_size;
- png_structp png_ptr = png_create_read_struct(
- PNG_LIBPNG_VER_STRING,
-@@ -125,11 +125,11 @@
-
- int compression_type;
- /* Extract embedded ICC profile */
-- if (info_ptr->valid & PNG_INFO_iCCP)
-+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_iCCP))
- {
- png_uint_32 retval = png_get_iCCP (png_ptr, info_ptr,
-- (png_charpp) &icc_profile_title, &compression_type,
-- (png_charpp) &icc_profile, (png_uint_32*) &icc_profile_size);
-+ &icc_profile_title, &compression_type,
-+ &icc_profile, (png_uint_32*) &icc_profile_size);
- if (retval != 0)
- {
- RSIccProfile *icc = rs_icc_profile_new_from_memory((gchar*)icc_profile, icc_profile_size, TRUE);
-diff -wbBur rawstudio-2.0/plugins/output-pngfile/output-pngfile.c rawstudio-2.0.my/plugins/output-pngfile/output-pngfile.c
---- rawstudio-2.0/plugins/output-pngfile/output-pngfile.c 2011-03-26 04:52:29.000000000 +0300
-+++ rawstudio-2.0.my/plugins/output-pngfile/output-pngfile.c 2012-01-23 15:04:59.000000000 +0400
-@@ -23,6 +23,7 @@
- #include <gettext.h>
- #include "config.h"
- #include <png.h>
-+#include <zlib.h>
-
- #define RS_TYPE_PNGFILE (rs_pngfile_type)
- #define RS_PNGFILE(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), RS_TYPE_PNGFILE, RSPngfile)) \ No newline at end of file
diff --git a/graphics/rawstudio/rawstudio.SlackBuild b/graphics/rawstudio/rawstudio.SlackBuild
deleted file mode 100644
index 170cb4a743..0000000000
--- a/graphics/rawstudio/rawstudio.SlackBuild
+++ /dev/null
@@ -1,130 +0,0 @@
-#!/bin/bash
-
-# Slackware Package Build Script for rawstudio
-# Home Page http://rawstudio.org/
-
-# Copyright (c) 2007-2015, Nishant Limbachia, Hoffman Estates, IL, USA
-# (nishant _AT_ mnspace _DOT_ net)
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of script must retain the above copyright notice,
-# this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
-# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
-# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
-# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
-# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
-# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by Robby Workman <rworkman@slackbuilds.org>
-# No additional license terms :-)
-
-# 20220226 bkw: fixed download URL, but this is still broken. Tried
-# various patches, tried latest git. Will come back to it.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM="rawstudio"
-VERSION=${VERSION:-2.0}
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -fr $TMP/$PRGNAM-$VERSION $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root.root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Add libgthread-2.0.so to linked-in library list
-find . -name "Makefile.in" -exec \
- sed -i "s,@PACKAGE_LIBS@,@PACKAGE_LIBS@ -lgthread-2.0,g" {} \;
-
-# Patches shamelessly copied from Arch Linux PKGBUILD:
-# https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/rawstudio
-
-# Patch to use lensfun > 0.3
-patch -p1 < $CWD/patches/lensfun03.patch
-
-# Patch to use libpng > 1.5. This patch is only useful on -current and will need to
-# be applied once -current releases. Uncomment if you are building on -current
-patch -p1 < $CWD/patches/libpng15.patch
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS -Wno-error=narrowing" \
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-static=no \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
- pixmaps/artwork.license $PKG/usr/doc/$PRGNAM-$VERSION
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/rawstudio/rawstudio.info b/graphics/rawstudio/rawstudio.info
deleted file mode 100644
index 7db2001f2b..0000000000
--- a/graphics/rawstudio/rawstudio.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="rawstudio"
-VERSION="2.0"
-HOMEPAGE="https://rawstudio.org"
-DOWNLOAD="https://slackware.uk/~urchlay/src/rawstudio-2.0.tar.xz"
-MD5SUM="10c8305dbf73a616f7ab414009fb5455"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="flickcurl"
-MAINTAINER="Nishant Limbachia"
-EMAIL="nishant@mnspace.net"
diff --git a/graphics/rawstudio/slack-desc b/graphics/rawstudio/slack-desc
deleted file mode 100644
index feb3f28bfd..0000000000
--- a/graphics/rawstudio/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-rawstudio: rawstudio (read and manipulate RAW images)
-rawstudio:
-rawstudio: Rawstudio is an open-source program to read and manipulate
-rawstudio: RAW images from most digital cameras. Rawstudio can convert
-rawstudio: RAW files into JPEG, PNG, or TIF images.
-rawstudio:
-rawstudio: Home Page: http://www.rawstudio.org/
-rawstudio:
-rawstudio:
-rawstudio:
-rawstudio: