summaryrefslogtreecommitdiffstats
path: root/graphics/openimageio
diff options
context:
space:
mode:
author Matteo Bernardini2019-05-04 07:46:43 +0200
committer Matteo Bernardini2019-05-04 07:46:43 +0200
commitfa1636226b6860de43aa40332badbd3ebcac50c8 (patch)
treeb9224f52ca65168511fbdf9ffc375527f55213dd /graphics/openimageio
parent8d0526bb95b4cd6732326f6c4b528dbbddd30e45 (diff)
downloadslackbuilds-current-20190504.1.tar.gz
20190504.1 global branch merge.current-20190504.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/openimageio')
-rw-r--r--graphics/openimageio/openimageio.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/openimageio/openimageio.SlackBuild b/graphics/openimageio/openimageio.SlackBuild
index f96cd057de..54a0c70b7b 100644
--- a/graphics/openimageio/openimageio.SlackBuild
+++ b/graphics/openimageio/openimageio.SlackBuild
@@ -77,14 +77,17 @@ find -L . \
# Remove bundled pugixml
#rm -f src/include/OpenImageIO/pugi*
-# save this for GCC 7.0
-#sed -i "s|std=c++11|std=c++11 -Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new|" CMakeLists.txt
+# newer compilers are stricter
+ADD_FLAGS="-Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new -Wno-error=stringop-truncation -Wno-error=sizeof-pointer-memaccess -Wno-error=class-memaccess"
+
+# needed for the newer boost
+sed -i "s|python-py|python|" src/python/CMakeLists.txt
mkdir -p build
cd build
cmake ../ \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11 $ADD_FLAGS" \
-DOPENJPEG_INCLUDE_DIR="/usr/include/openmj2-2.1" \
-DOPENJPEG_OPENJPEG_LIBRARIES="openmj2" \
-DCMAKE_BUILD_TYPE=Release \
@@ -99,6 +102,7 @@ cd build
-DUSE_PYTHON:BOOL=TRUE \
-DUSE_PYTHON3:BOOL=TRUE \
-DUSE_EXTERNAL_PUGIXML:BOOL=FALSE \
+ -DBoost_NO_BOOST_CMAKE=ON
make
make install DESTDIR=$PKG