summaryrefslogtreecommitdiffstats
path: root/graphics/openimageio/openimageio.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini2018-10-06 08:26:41 +0200
committer Matteo Bernardini2018-10-06 08:26:41 +0200
commit389b3c43f33cdd25ba13cfc9b5ee1674106fbc13 (patch)
treedd8081a1bc6dbfeec30e68b4774b144864f2bef0 /graphics/openimageio/openimageio.SlackBuild
parent4f4d6a32cce667ebff01e9d73878e4894c0328d4 (diff)
downloadslackbuilds-current-20181006.1.tar.gz
20181006.1 global branch merge.current-20181006.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/openimageio/openimageio.SlackBuild')
-rw-r--r--graphics/openimageio/openimageio.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/openimageio/openimageio.SlackBuild b/graphics/openimageio/openimageio.SlackBuild
index 29fbcf852e..146e5df7c5 100644
--- a/graphics/openimageio/openimageio.SlackBuild
+++ b/graphics/openimageio/openimageio.SlackBuild
@@ -77,14 +77,17 @@ find -L . \
# Remove bundled pugixml
#rm -f src/include/OpenImageIO/pugi*
-# save this for GCC 7.0
-#sed -i "s|std=c++11|std=c++11 -Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new|" CMakeLists.txt
+# newer compilers are stricter
+ADD_FLAGS="-Wno-error=maybe-uninitialized -Wno-error=format-truncation -Wno-error=noexcept-type -faligned-new -Wno-error=stringop-truncation -Wno-error=sizeof-pointer-memaccess -Wno-error=class-memaccess"
+
+# needed for the newer boost
+sed -i "s|python-py|python|" src/python/CMakeLists.txt
mkdir -p build
cd build
cmake ../ \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11 $ADD_FLAGS" \
-DOPENJPEG_INCLUDE_DIR="/usr/include/openmj2-2.1" \
-DOPENJPEG_OPENJPEG_LIBRARIES="openmj2" \
-DCMAKE_BUILD_TYPE=Release \