summaryrefslogtreecommitdiffstats
path: root/gis/openorienteering-mapper
diff options
context:
space:
mode:
author ArTourter2021-10-26 20:57:05 +0200
committer Willy Sudiarto Raharjo2021-10-27 03:16:42 +0200
commit76d36aa9160dcee438ec6aa7486196a4a79f255f (patch)
tree6861fd4b4151e32b7ef7b4a65ded85c231690f61 /gis/openorienteering-mapper
parent0e6e00a2f8d8cb7f7b947b6c928dc7fe2a7a9ff2 (diff)
downloadslackbuilds-76d36aa9160dcee438ec6aa7486196a4a79f255f.tar.gz
gis/openorienteering-mapper: updated to version 0.9.5
update to include patch from debian submitted as a PR to upstream to support proj version 8 which removes the deprecated proj_api.h Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/openorienteering-mapper')
-rw-r--r--gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch35
-rw-r--r--gis/openorienteering-mapper/fix_doc_path.diff11
-rw-r--r--gis/openorienteering-mapper/openorienteering-mapper.SlackBuild6
-rw-r--r--gis/openorienteering-mapper/openorienteering-mapper.info6
4 files changed, 42 insertions, 16 deletions
diff --git a/gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch b/gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch
new file mode 100644
index 0000000000..6545099e95
--- /dev/null
+++ b/gis/openorienteering-mapper/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch
@@ -0,0 +1,35 @@
+From 69977dfd4cbb8608aafa8ca8b5388d4983f5430a Mon Sep 17 00:00:00 2001
+From: Bas Couwenberg <sebastic@debian.org>
+Date: Sat, 23 Oct 2021 17:08:31 +0200
+Subject: [PATCH] Add support for proj.h, proj_api.h is removed in PROJ 8.
+
+---
+ cmake/FindPROJ4.cmake | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
+
+diff --git a/cmake/FindPROJ4.cmake b/cmake/FindPROJ4.cmake
+index 093deaa79..10dfc7afa 100644
+--- a/cmake/FindPROJ4.cmake
++++ b/cmake/FindPROJ4.cmake
+@@ -91,6 +91,21 @@ if(PROJ4_INCLUDE_DIR AND EXISTS "${PROJ4_INCLUDE_DIR}/proj_api.h")
+ string(REGEX REPLACE "^.*PJ_VERSION [0-9][0-9]([0-9]).*$" "\\1" PROJ4_VERSION_PATCH "${PROJ4_H}")
+ set(PROJ4_VERSION "${PROJ4_VERSION_MAJOR}.${PROJ4_VERSION_MINOR}.${PROJ4_VERSION_PATCH}")
+ set(PROJ4_VERSION_COUNT 3)
++else()
++ find_path(PROJ4_INCLUDE_DIR NAMES proj.h ${_PROJ4_SEARCH} PATH_SUFFIXES include)
++ mark_as_advanced(PROJ4_INCLUDE_DIR)
++
++ if(PROJ4_INCLUDE_DIR AND EXISTS "${PROJ4_INCLUDE_DIR}/proj.h")
++ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj.h" PROJ_VERSION_MAJOR REGEX "^#define PROJ_VERSION_MAJOR [0-9]+$")
++ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj.h" PROJ_VERSION_MINOR REGEX "^#define PROJ_VERSION_MINOR [0-9]+$")
++ file(STRINGS "${PROJ4_INCLUDE_DIR}/proj.h" PROJ_VERSION_PATCH REGEX "^#define PROJ_VERSION_PATCH [0-9]+$")
++
++ string(REGEX REPLACE "^.*PROJ_VERSION_[A-Z]+ ([0-9]).*$" "\\1" PROJ4_VERSION_MAJOR "${PROJ_VERSION_MAJOR}")
++ string(REGEX REPLACE "^.*PROJ_VERSION_[A-Z]+ ([0-9]).*$" "\\1" PROJ4_VERSION_MINOR "${PROJ_VERSION_MINOR}")
++ string(REGEX REPLACE "^.*PROJ_VERSION_[A-Z]+ ([0-9]).*$" "\\1" PROJ4_VERSION_PATCH "${PROJ_VERSION_PATCH}")
++ set(PROJ4_VERSION "${PROJ4_VERSION_MAJOR}.${PROJ4_VERSION_MINOR}.${PROJ4_VERSION_PATCH}")
++ set(PROJ4_VERSION_COUNT 3)
++ endif()
+ endif()
+
+ # Allow PROJ4_LIBRARY to be set manually, as the location of the proj library
diff --git a/gis/openorienteering-mapper/fix_doc_path.diff b/gis/openorienteering-mapper/fix_doc_path.diff
deleted file mode 100644
index 87b1586cf0..0000000000
--- a/gis/openorienteering-mapper/fix_doc_path.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- mapper-0.9.0/CMakeLists.txt.orig 2019-10-24 00:33:05.001359242 +0300
-+++ mapper-0.9.0/CMakeLists.txt 2019-10-24 00:33:50.964840135 +0300
-@@ -133,7 +133,7 @@
- set(MAPPER_RUNTIME_DESTINATION "bin")
- set(MAPPER_LIBRARY_DESTINATION "lib/${Mapper_PACKAGE_NAME}")
- set(MAPPER_DATA_DESTINATION "share/${Mapper_PACKAGE_NAME}")
-- set(MAPPER_ABOUT_DESTINATION "share/doc/${Mapper_PACKAGE_NAME}")
-+ set(MAPPER_ABOUT_DESTINATION "doc/${Mapper_PACKAGE_NAME}-${Mapper_VERSION}")
- endif()
-
- if(CMAKE_CROSSCOMPILING)
diff --git a/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild b/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild
index bd0af2782e..ed77cca493 100644
--- a/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild
+++ b/gis/openorienteering-mapper/openorienteering-mapper.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=openorienteering-mapper
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/fix_doc_path.diff
+# patch for Proj 8 submitted PR to upstream from debian
+patch -p1 < $CWD/69977dfd4cbb8608aafa8ca8b5388d4983f5430a.patch
mkdir -p build
cd build
@@ -88,6 +89,7 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_DOCDIR="/usr/doc/$PRGNAM-$VERSION" \
-DLICENSING_PROVIDER:BOOL=OFF \
-DMapper_PACKAGE_NAME=$PRGNAM \
-Wno-dev ..
diff --git a/gis/openorienteering-mapper/openorienteering-mapper.info b/gis/openorienteering-mapper/openorienteering-mapper.info
index f05b80055e..c5d4b16d5a 100644
--- a/gis/openorienteering-mapper/openorienteering-mapper.info
+++ b/gis/openorienteering-mapper/openorienteering-mapper.info
@@ -1,8 +1,8 @@
PRGNAM="openorienteering-mapper"
-VERSION="0.9.0"
+VERSION="0.9.5"
HOMEPAGE="https://www.openorienteering.org/apps/mapper/"
-DOWNLOAD="https://github.com/OpenOrienteering/mapper/archive/v0.9.0/mapper-0.9.0.tar.gz"
-MD5SUM="7135d60bcacaba0fde002543705c9eea"
+DOWNLOAD="https://github.com/OpenOrienteering/mapper/archive/v0.9.5/mapper-0.9.5.tar.gz"
+MD5SUM="87cde1b4bbb94704ec1dc356674ec92d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gdal polyclipping proj"