summaryrefslogtreecommitdiffstats
path: root/games/pcsxr/zlib129fix.patch
diff options
context:
space:
mode:
author Matteo Bernardini2019-09-14 07:57:43 +0200
committer Matteo Bernardini2019-09-14 07:57:43 +0200
commitde40343a1db85e9c173db1c195923e0157d93cfe (patch)
tree72c35cdc13e9823bcfb4d26866f4b97b1440420b /games/pcsxr/zlib129fix.patch
parent50b7e832ae3d4c1f51d3d0e93ab9face1a8d036d (diff)
downloadslackbuilds-current-20190914.1.tar.gz
20190914.1 global branch merge.current-20190914.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/pcsxr/zlib129fix.patch')
-rw-r--r--games/pcsxr/zlib129fix.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/pcsxr/zlib129fix.patch b/games/pcsxr/zlib129fix.patch
new file mode 100644
index 0000000000..632e1ceffe
--- /dev/null
+++ b/games/pcsxr/zlib129fix.patch
@@ -0,0 +1,34 @@
+diff --git a/pcsxr/configure.ac b/pcsxr/configure.ac
+index 300bb18..128b4f9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -113,6 +113,9 @@ if test "x$have_xtest" = xno; then
+ AC_MSG_ERROR([unable to find xtest headers])
+ fi
+
++AC_CHECK_LIB(z, uncompress2,
++[ AC_DEFINE([HAVE_UNCOMPRESS2], [1], [Define if libz supports uncompress2]) ])
++
+ AM_CONDITIONAL(USE_LIBCDIO, false)
+
+ AC_ARG_ENABLE(libcdio, [ --enable-libcdio use GNU libcdio for CD-ROM support (default=no)],
+diff --git a/pcsxr/libpcsxcore/cdriso.c b/pcsxr/libpcsxcore/cdriso.c
+index 04e866d..fb7f28a 100644
+--- a/libpcsxcore/cdriso.c
++++ b/libpcsxcore/cdriso.c
+@@ -1219,6 +1219,7 @@ static int cdread_sub_mixed(FILE *f, unsigned int base, void *dest, int sector)
+ return ret;
+ }
+
++#ifndef HAVE_UNCOMPRESS2
+ static int uncompress2(void *out, unsigned long *out_size, void *in, unsigned long in_size)
+ {
+ static z_stream z;
+@@ -1249,6 +1250,7 @@ static int uncompress2(void *out, unsigned long *out_size, void *in, unsigned lo
+ *out_size -= z.avail_out;
+ return ret == 1 ? 0 : ret;
+ }
++#endif
+
+ static int cdread_compressed(FILE *f, unsigned int base, void *dest, int sector)
+ {