summaryrefslogtreecommitdiffstats
path: root/games/brainparty/patches
diff options
context:
space:
mode:
author Matteo Bernardini2020-09-12 20:31:23 +0200
committer Matteo Bernardini2020-09-12 20:31:23 +0200
commitb38ad4464a26bbe8c11a8ec3d2a44467a9f80c19 (patch)
tree79336dddbe92db427d5b2b9fd50541954114ff5c /games/brainparty/patches
parentb2643f7815ef7bbf399288ba0e383b0f293ce05e (diff)
downloadslackbuilds-current-20200912.1.tar.gz
20200912.1 global branch merge.current-20200912.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/brainparty/patches')
-rw-r--r--games/brainparty/patches/gcc-6.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/brainparty/patches/gcc-6.patch b/games/brainparty/patches/gcc-6.patch
new file mode 100644
index 0000000000..67dfadd540
--- /dev/null
+++ b/games/brainparty/patches/gcc-6.patch
@@ -0,0 +1,47 @@
+Description: Fix FTBFS on GCC 6 by removing use of hash_set class
+Author: James Cowgill <jcowgill@debian.org>
+Bug-Debian: https://bugs.debian.org/811885
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/WordList.h
++++ b/WordList.h
+@@ -18,24 +18,11 @@
+ #ifndef __WORDLIST_H__
+ #define __WORDLIST_H__
+
++#include <string>
+ #include <vector>
+-#include <ext/hash_set>
++#include <unordered_set>
+
+-using namespace std;
+-using namespace __gnu_cxx;
+-
+-namespace __gnu_cxx
+-{
+- template<> struct hash< std::string >
+- {
+- size_t operator()( const std::string& x ) const
+- {
+- return hash< const char* >()( x.c_str() );
+- }
+- };
+-}
+-
+-typedef hash_set<string, hash<string> > string_hash_set;
++typedef std::unordered_set<std::string> string_hash_set;
+
+ class WordList {
+ private:
+--- a/Makefile
++++ b/Makefile
+@@ -17,6 +17,9 @@ else
+ OSXCOMPAT =
+ endif
+
++# enable c++11
++CXXFLAGS += -std=c++11
++
+ # object files have corresponding source files
+ CXX = g++
+