summaryrefslogtreecommitdiffstats
path: root/development/gcc5/patches/gcc-no_fixincludes.diff
diff options
context:
space:
mode:
author Matteo Bernardini2018-07-21 18:30:25 +0200
committer Matteo Bernardini2018-07-21 18:30:25 +0200
commitedc3e434486c95e7ee8e227def485cc9e068f377 (patch)
tree85312122d425cbf4fcc00475938a40451c4dc97c /development/gcc5/patches/gcc-no_fixincludes.diff
parentec1a4a932c386f509cf24092be7aa38837d57ddd (diff)
downloadslackbuilds-current-20180722.1.tar.gz
20180721.2 global branch merge.current-20180722.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development/gcc5/patches/gcc-no_fixincludes.diff')
-rw-r--r--development/gcc5/patches/gcc-no_fixincludes.diff27
1 files changed, 27 insertions, 0 deletions
diff --git a/development/gcc5/patches/gcc-no_fixincludes.diff b/development/gcc5/patches/gcc-no_fixincludes.diff
new file mode 100644
index 0000000000..52b661613d
--- /dev/null
+++ b/development/gcc5/patches/gcc-no_fixincludes.diff
@@ -0,0 +1,27 @@
+--- ./gcc/Makefile.in.orig 2010-04-02 02:49:06.000000000 -0500
++++ ./gcc/Makefile.in 2010-08-01 16:55:30.088318841 -0500
+@@ -3864,9 +3864,9 @@
+ chmod a+r $${fix_dir}/limits.h; \
+ done
+ # Install the README
+- rm -f include-fixed/README
+- cp $(srcdir)/../fixincludes/README-fixinc include-fixed/README
+- chmod a+r include-fixed/README
++# rm -f include-fixed/README
++# cp $(srcdir)/../fixincludes/README-fixinc include-fixed/README
++# chmod a+r include-fixed/README
+ $(STAMP) $@
+
+ .PHONY: install-gcc-tooldir
+@@ -3947,10 +3947,7 @@
+ (TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
+ SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
+ gcc_dir=`${PWD_COMMAND}` ; \
+- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
+- cd $(build_objdir)/fixincludes && \
+- $(SHELL) ./fixinc.sh "$${gcc_dir}/$${fix_dir}" \
+- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) ); \
++ export TARGET_MACHINE srcdir SHELL MACRO_LIST ); \
+ rm -f $${fix_dir}/syslimits.h; \
+ if [ -f $${fix_dir}/limits.h ]; then \
+ mv $${fix_dir}/limits.h $${fix_dir}/syslimits.h; \