summaryrefslogtreecommitdiffstats
path: root/desktop/polybar
diff options
context:
space:
mode:
author Matteo Bernardini2021-10-21 14:16:59 +0200
committer Willy Sudiarto Raharjo2021-10-22 08:03:40 +0200
commita8b18fc081588e0495f704e6eea6c56c77609fc6 (patch)
treec6feaa6fe9fd80383e8f1c45190cedd55d01bed7 /desktop/polybar
parent272f1dde07081627390e5c43dfacbea687d26a25 (diff)
downloadslackbuilds-a8b18fc081588e0495f704e6eea6c56c77609fc6.tar.gz
desktop/polybar: Updated for version 3.5.7.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/polybar')
-rw-r--r--desktop/polybar/00165e1a6d5dd61bc153e1352b21ec07fc81245d.patch44
-rw-r--r--desktop/polybar/README3
-rw-r--r--desktop/polybar/polybar.SlackBuild27
-rw-r--r--desktop/polybar/polybar.info10
4 files changed, 20 insertions, 64 deletions
diff --git a/desktop/polybar/00165e1a6d5dd61bc153e1352b21ec07fc81245d.patch b/desktop/polybar/00165e1a6d5dd61bc153e1352b21ec07fc81245d.patch
deleted file mode 100644
index 81783617b9..0000000000
--- a/desktop/polybar/00165e1a6d5dd61bc153e1352b21ec07fc81245d.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 00165e1a6d5dd61bc153e1352b21ec07fc81245d Mon Sep 17 00:00:00 2001
-From: patrick96 <p.ziegler96@gmail.com>
-Date: Sun, 11 Feb 2018 21:27:52 +0100
-Subject: [PATCH] fix(generators): Add support for eventstruct
-
-Newer xcb-proto commits after the 1.12 release require the 'eventstruct'
-key in the output dictionary, otherwise the generator crashes.
-
-I don't see a need for xpp to actually support the eventstruct key and
-thus it uses a NOP lambda function
----
- generators/cpp_client.py | 19 ++++++++++---------
- 1 file changed, 10 insertions(+), 9 deletions(-)
-
-diff --git a/generators/cpp_client.py b/generators/cpp_client.py
-index 20d116f..709e8d8 100644
---- a/generators/cpp_client.py
-+++ b/generators/cpp_client.py
-@@ -3130,15 +3130,16 @@ def cpp_type_classes():
- # }
-
- # Must create an "output" dictionary before any xcbgen imports.
--output = {'open' : c_open,
-- 'close' : c_close,
-- 'simple' : c_simple, # lambda x, y: None,
-- 'enum' : lambda x, y: None,
-- 'struct' : lambda x, y: None,
-- 'union' : lambda x, y: None,
-- 'request' : c_request,
-- 'event' : cpp_event,
-- 'error' : cpp_error,
-+output = {'open' : c_open,
-+ 'close' : c_close,
-+ 'simple' : c_simple, # lambda x, y: None,
-+ 'enum' : lambda x, y: None,
-+ 'struct' : lambda x, y: None,
-+ 'union' : lambda x, y: None,
-+ 'request' : c_request,
-+ 'event' : cpp_event,
-+ 'error' : cpp_error,
-+ 'eventstruct' : lambda x, y: None,
- }
-
- # Boilerplate below this point
diff --git a/desktop/polybar/README b/desktop/polybar/README
index 3793085107..a586e9646e 100644
--- a/desktop/polybar/README
+++ b/desktop/polybar/README
@@ -6,3 +6,6 @@ Optional dependencies for extended module support:
* jsoncpp required by internal/i3
* libmpdclient required by internal/mpd
* siji-font for additional font support
+
+Building the documentation and the man pages requires the optional
+dependency Sphinx.
diff --git a/desktop/polybar/polybar.SlackBuild b/desktop/polybar/polybar.SlackBuild
index eb1a40fe22..3dd1cd15fb 100644
--- a/desktop/polybar/polybar.SlackBuild
+++ b/desktop/polybar/polybar.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=polybar
-VERSION=${VERSION:-3.3.1}
+VERSION=${VERSION:-3.5.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -73,9 +73,9 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
# Extract the Git modules to lib
-for mod in i3ipcpp-0.7.0 xpp-1.4.0; do
+for mod in i3ipcpp-0.7.0 xpp-20210303_7a9960b; do
rm -rf lib/${mod%-*}
- tar xvf $CWD/$mod.tar.gz
+ tar xvf $CWD/$mod.tar.?z
mv $mod lib/${mod%-*}
done
chown -R root:root .
@@ -85,16 +85,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-( cd lib/xpp
- patch -p1 < $CWD/00165e1a6d5dd61bc153e1352b21ec07fc81245d.patch )
-
-# Fixes install location
-sed -i -e '/share\/doc\/polybar/s/share\///' doc/CMakeLists.txt
-sed -i -e "/DESTINATION doc\/polybar/s/polybar/$PRGNAM-$VERSION/" doc/CMakeLists.txt
-sed -i -e '/share\/man\/man1/s/share\///' man/CMakeLists.txt
-
# Fixes version
-sed -i -e "/execute_process(COMMAND git describe --tags --dirty=-git/s/git.*/echo $VERSION/" include/CMakeLists.txt
+sed -i -e "/execute_process(COMMAND git describe --tags --dirty=-git/s/git.*/echo $VERSION/" include/CMakeLists.txt || exit 1
+
+export PYTHON=python3
mkdir -p build
cd build
@@ -102,13 +96,16 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -Wno-error=implicit-fallthrough -Wno-error=stringop-truncation -Wno-error=deprecated-copy" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
-DCMAKE_BUILD_TYPE=Release ..
- make -j1
+ make
make install/strip DESTDIR=$PKG
cd ..
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+find $PKG/usr/man -type f -exec gzip -9 {} \; || true
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.md SUPPORT.md $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/desktop/polybar/polybar.info b/desktop/polybar/polybar.info
index 1d76fa2565..05fa0147f1 100644
--- a/desktop/polybar/polybar.info
+++ b/desktop/polybar/polybar.info
@@ -1,12 +1,12 @@
PRGNAM="polybar"
-VERSION="3.3.1"
+VERSION="3.5.7"
HOMEPAGE="https://github.com/polybar/polybar"
-DOWNLOAD="https://github.com/polybar/polybar/archive/3.3.1/polybar-3.3.1.tar.gz \
+DOWNLOAD="https://github.com/polybar/polybar/archive/3.5.7/polybar-3.5.7.tar.gz \
https://github.com/jaagr/i3ipcpp/archive/v0.7.0/i3ipcpp-0.7.0.tar.gz \
- https://github.com/jaagr/xpp/archive/1.4.0/xpp-1.4.0.tar.gz"
-MD5SUM="67006090c404939ef625d49c902839d4 \
+ https://ponce.cc/slackware/sources/repo/xpp-20210303_7a9960b.tar.xz"
+MD5SUM="edd10b832951de562e5fb815371441d1 \
572b9f058bab2d19fcc3f44f4601b739 \
- d1a7db82fb5737cc91f386d2bcbb1286"
+ 261f9f5f4f8bd21454820df20150af6c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="xcb-util-xrm"