summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2023-04-28 02:21:19 +0200
committer Willy Sudiarto Raharjo2023-04-29 13:11:39 +0200
commitfc741fec2c26957e6d6ba180a2df243e5d001f09 (patch)
tree421152137a3aa669be8fc9e0d37176c4d1a6fbc8
parent648169422dd198c70954c22150fcce4cade107dc (diff)
downloadslackbuilds-fc741fec2c26957e6d6ba180a2df243e5d001f09.tar.gz
python/python2-pyasn1: Added (ASN.1 types and codecs in Python)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-pyasn1/README3
-rw-r--r--python/python2-pyasn1/python2-pyasn1.SlackBuild95
-rw-r--r--python/python2-pyasn1/python2-pyasn1.info10
-rw-r--r--python/python2-pyasn1/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/python/python2-pyasn1/README b/python/python2-pyasn1/README
new file mode 100644
index 0000000000..57b8687706
--- /dev/null
+++ b/python/python2-pyasn1/README
@@ -0,0 +1,3 @@
+pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python.
+
+This is the Python 2 build of pyasn1.
diff --git a/python/python2-pyasn1/python2-pyasn1.SlackBuild b/python/python2-pyasn1/python2-pyasn1.SlackBuild
new file mode 100644
index 0000000000..e094702018
--- /dev/null
+++ b/python/python2-pyasn1/python2-pyasn1.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for python2-pyasn1
+
+# Copyright 2011-2018 Markus Reichelt, Aachen, DE
+# Copyright 2022-2023 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-pyasn1
+VERSION=${VERSION:-0.4.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=pyasn1
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar LICENSE.rst README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pyasn1/python2-pyasn1.info b/python/python2-pyasn1/python2-pyasn1.info
new file mode 100644
index 0000000000..7f5b2d7857
--- /dev/null
+++ b/python/python2-pyasn1/python2-pyasn1.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-pyasn1"
+VERSION="0.4.8"
+HOMEPAGE="https://github.com/etingof/pyasn1"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pyasn1/pyasn1-0.4.8.tar.gz"
+MD5SUM="dffae4ff9f997a83324b3f33fe62be54"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python2-pyasn1/slack-desc b/python/python2-pyasn1/slack-desc
new file mode 100644
index 0000000000..7cde2e6924
--- /dev/null
+++ b/python/python2-pyasn1/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pyasn1: python2-pyasn1 (ASN.1 types and codecs in Python)
+python2-pyasn1:
+python2-pyasn1: pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python.
+python2-pyasn1:
+python2-pyasn1: Some features include:
+python2-pyasn1: - Generic implementation of ASN.1 types (X.208)
+python2-pyasn1: - Fully standard compliant BER/CER/DER codecs
+python2-pyasn1: - 100% Python, works with Python 2.2 and later
+python2-pyasn1:
+python2-pyasn1: Homepage: https://github.com/etingof/pyasn1
+python2-pyasn1: