summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2024-02-10 00:23:44 +0100
committer Willy Sudiarto Raharjo2024-02-10 10:17:19 +0100
commiteec19c7b3f04e17f4d82d70bb2ba859e2a6f46ab (patch)
tree2d916b4ea1e9cb64f13a917d871ea2d27b2ec368
parent06a33c35ac08ad02592d0bee584b523d6203fd8a (diff)
downloadslackbuilds-eec19c7b3f04e17f4d82d70bb2ba859e2a6f46ab.tar.gz
python/python3-tenacity: Added (retrying library).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-tenacity/README3
-rw-r--r--python/python3-tenacity/python3-tenacity.SlackBuild82
-rw-r--r--python/python3-tenacity/python3-tenacity.info10
-rw-r--r--python/python3-tenacity/slack-desc19
4 files changed, 114 insertions, 0 deletions
diff --git a/python/python3-tenacity/README b/python/python3-tenacity/README
new file mode 100644
index 0000000000..ac7ad67519
--- /dev/null
+++ b/python/python3-tenacity/README
@@ -0,0 +1,3 @@
+Tenacity is an Apache 2.0 licensed general-purpose retrying library,
+written in Python, to simplify the task of adding retry behavior to
+just about anything.
diff --git a/python/python3-tenacity/python3-tenacity.SlackBuild b/python/python3-tenacity/python3-tenacity.SlackBuild
new file mode 100644
index 0000000000..02c6f469b7
--- /dev/null
+++ b/python/python3-tenacity/python3-tenacity.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for python3-tenacity
+
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-tenacity
+VERSION=${VERSION:-8.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=tenacity
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -Dm644 LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-tenacity/python3-tenacity.info b/python/python3-tenacity/python3-tenacity.info
new file mode 100644
index 0000000000..6d79672ce4
--- /dev/null
+++ b/python/python3-tenacity/python3-tenacity.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-tenacity"
+VERSION="8.2.3"
+HOMEPAGE="https://github.com/jd/tenacity"
+DOWNLOAD="https://github.com/jd/tenacity/archive/refs/tags/8.2.3/tenacity-8.2.3.tar.gz"
+MD5SUM="8a6a7bde47f448ed3c27237ae406b66e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/python/python3-tenacity/slack-desc b/python/python3-tenacity/slack-desc
new file mode 100644
index 0000000000..ab67f9bcb3
--- /dev/null
+++ b/python/python3-tenacity/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-tenacity: python3-tenacity (Retrying library for Python)
+python3-tenacity:
+python3-tenacity: Tenacity is an Apache 2.0 licensed general-purpose retrying library,
+python3-tenacity: written in Python, to simplify the task of adding retry behavior to
+python3-tenacity: just about anything.
+python3-tenacity:
+python3-tenacity:
+python3-tenacity:
+python3-tenacity:
+python3-tenacity:
+python3-tenacity: