summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2023-04-29 23:49:20 +0200
committer Willy Sudiarto Raharjo2023-05-05 02:52:24 +0200
commite9f09f5b122f1f85e6f65fd1cd0570aadf40cb90 (patch)
tree1ce6af62e274b7e9f8612b55ebaf4fcb1e9783da
parent53d3fe71469089484a26b8500b7ebfa1e87e336d (diff)
downloadslackbuilds-e9f09f5b122f1f85e6f65fd1cd0570aadf40cb90.tar.gz
python/asn1crypto: Remove asn1crypto
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/asn1crypto/README3
-rw-r--r--python/asn1crypto/asn1crypto.SlackBuild98
-rw-r--r--python/asn1crypto/asn1crypto.info10
-rw-r--r--python/asn1crypto/slack-desc19
4 files changed, 0 insertions, 130 deletions
diff --git a/python/asn1crypto/README b/python/asn1crypto/README
deleted file mode 100644
index 2093f7fe94..0000000000
--- a/python/asn1crypto/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Fast ASN.1 parser and serializer with definitions for private keys,
-public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
-PKCS#12, PKCS#5, X.509 and TSPB.
diff --git a/python/asn1crypto/asn1crypto.SlackBuild b/python/asn1crypto/asn1crypto.SlackBuild
deleted file mode 100644
index 5fbdf2e27e..0000000000
--- a/python/asn1crypto/asn1crypto.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for asn1crypto
-#
-# Copyright 2017-2018 Markus Reichelt, Aachen, DE
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=asn1crypto
-VERSION=${VERSION:-1.5.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE changelog.md docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/asn1crypto/asn1crypto.info b/python/asn1crypto/asn1crypto.info
deleted file mode 100644
index 1e739d0f11..0000000000
--- a/python/asn1crypto/asn1crypto.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="asn1crypto"
-VERSION="1.5.1"
-HOMEPAGE="https://pypi.python.org/pypi/asn1crypto"
-DOWNLOAD="https://pypi.python.org/packages/source/a/asn1crypto/asn1crypto-1.5.1.tar.gz"
-MD5SUM="f7a5271af9b81246fbdf57d703afce2f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/asn1crypto/slack-desc b/python/asn1crypto/slack-desc
deleted file mode 100644
index 6a6e7aa34f..0000000000
--- a/python/asn1crypto/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-asn1crypto: asn1crypto (Fast ASN.1 parser and serializer)
-asn1crypto:
-asn1crypto: https://pypi.python.org/pypi/asn1crypto
-asn1crypto:
-asn1crypto:
-asn1crypto:
-asn1crypto:
-asn1crypto:
-asn1crypto:
-asn1crypto:
-asn1crypto: