summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall2021-05-03 07:48:47 +0200
committer Robby Workman2021-05-03 08:49:56 +0200
commite5286256a9fd41c98637113ff48617051fcaec3f (patch)
treefc3d23bd82c2c7ad6643a0d693c256af815f639f
parent0dc52667fc998173e7ef13967759e25f344e7e87 (diff)
downloadslackbuilds-e5286256a9fd41c98637113ff48617051fcaec3f.tar.gz
python/python-Levenshtein: Renamed python2-Levenshtein.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
-rw-r--r--python/python-Levenshtein/slack-desc19
-rw-r--r--python/python2-Levenshtein/README (renamed from python/python-Levenshtein/README)0
-rw-r--r--python/python2-Levenshtein/python2-Levenshtein.SlackBuild (renamed from python/python-Levenshtein/python-Levenshtein.SlackBuild)11
-rw-r--r--python/python2-Levenshtein/python2-Levenshtein.info (renamed from python/python-Levenshtein/python-Levenshtein.info)2
-rw-r--r--python/python2-Levenshtein/slack-desc19
5 files changed, 26 insertions, 25 deletions
diff --git a/python/python-Levenshtein/slack-desc b/python/python-Levenshtein/slack-desc
deleted file mode 100644
index deea034f42..0000000000
--- a/python/python-Levenshtein/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-Levenshtein: python-Levenshtein (string distance calculation module)
-python-Levenshtein:
-python-Levenshtein: python-levenhstein is a C extension module for Python that can be
-python-Levenshtein: used for fast calculation of string distances with the Levenshtein
-python-Levenshtein: algorithm, as well as some other methods.
-python-Levenshtein:
-python-Levenshtein: The python-Levenshtein website can be found at:
-python-Levenshtein: https://pypi.python.org/pypi/python-Levenshtein/
-python-Levenshtein:
-python-Levenshtein:
-python-Levenshtein:
diff --git a/python/python-Levenshtein/README b/python/python2-Levenshtein/README
index d931876c54..d931876c54 100644
--- a/python/python-Levenshtein/README
+++ b/python/python2-Levenshtein/README
diff --git a/python/python-Levenshtein/python-Levenshtein.SlackBuild b/python/python2-Levenshtein/python2-Levenshtein.SlackBuild
index 07d2019e45..7f2a52b573 100644
--- a/python/python-Levenshtein/python-Levenshtein.SlackBuild
+++ b/python/python2-Levenshtein/python2-Levenshtein.SlackBuild
@@ -4,7 +4,8 @@
# Written by Jick Nan (jick.nan@gmail.com)
-PRGNAM=python-Levenshtein
+PRGNAM=python2-Levenshtein
+SRCNAM=python-Levenshtein
VERSION=${VERSION:-0.10.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,9 +42,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar -xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -51,7 +52,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-Levenshtein/python-Levenshtein.info b/python/python2-Levenshtein/python2-Levenshtein.info
index 6c42ac48b5..5383cdb23d 100644
--- a/python/python-Levenshtein/python-Levenshtein.info
+++ b/python/python2-Levenshtein/python2-Levenshtein.info
@@ -1,4 +1,4 @@
-PRGNAM="python-Levenshtein"
+PRGNAM="python2-Levenshtein"
VERSION="0.10.2"
HOMEPAGE="https://pypi.python.org/pypi/python-Levenshtein/"
DOWNLOAD="https://pypi.python.org/packages/source/p/python-Levenshtein/python-Levenshtein-0.10.2.tar.gz"
diff --git a/python/python2-Levenshtein/slack-desc b/python/python2-Levenshtein/slack-desc
new file mode 100644
index 0000000000..948c9d012b
--- /dev/null
+++ b/python/python2-Levenshtein/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-Levenshtein: python2-Levenshtein (string distance calculation module)
+python2-Levenshtein:
+python2-Levenshtein: python2-levenhstein is a C extension module for Python that can be
+python2-Levenshtein: used for fast calculation of string distances with the Levenshtein
+python2-Levenshtein: algorithm, as well as some other methods.
+python2-Levenshtein:
+python2-Levenshtein: The python2-Levenshtein website can be found at:
+python2-Levenshtein: https://pypi.python.org/pypi/python-Levenshtein/
+python2-Levenshtein:
+python2-Levenshtein:
+python2-Levenshtein: