summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall2021-05-15 17:28:34 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:13 +0200
commite469f4174da3db0c0b70c296be2aeaf8b390e97e (patch)
treec471ef7e04a266583dfcd167d9fe0e63db1d4414
parenta29d1f4f891549b0ed5b431a70e34db225ded76c (diff)
downloadslackbuilds-e469f4174da3db0c0b70c296be2aeaf8b390e97e.tar.gz
python/flake8: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/flake8/flake8.SlackBuild2
-rw-r--r--python/flake8/flake8.info2
2 files changed, 2 insertions, 2 deletions
diff --git a/python/flake8/flake8.SlackBuild b/python/flake8/flake8.SlackBuild
index 6a9b7bfd70..822d5d36f5 100644
--- a/python/flake8/flake8.SlackBuild
+++ b/python/flake8/flake8.SlackBuild
@@ -72,7 +72,7 @@ find -L . \
# Ignores setuptools version, it works for me
sed -i "s/setuptools >= 30\",/\"/" setup.py
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/flake8/flake8.info b/python/flake8/flake8.info
index f78f6b7a63..47e635857f 100644
--- a/python/flake8/flake8.info
+++ b/python/flake8/flake8.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.python.org/packages/1e/ab/7730f6d6cdf73a3b7f98a2fe3b2cdf6
MD5SUM="7e5fe39d578a2c2d0962b61b35b8c3fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pytest-runner pycodestyle pyflakes python-mccabe ConfigParser"
+REQUIRES="pytest-runner pycodestyle pyflakes python2-mccabe ConfigParser"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"