summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author brobr2021-10-15 12:57:14 +0200
committer Willy Sudiarto Raharjo2021-10-15 19:23:52 +0200
commitceafa2e6cdc5452974edd65b2ee8632e48cd97f7 (patch)
treede5a4a318176f8e18e8ecddfdd39a8f7bed01a2f
parenta0d85d03c0aa76bfde61b8fe75fa0b485e31cbfb (diff)
downloadslackbuilds-ceafa2e6cdc5452974edd65b2ee8632e48cd97f7.tar.gz
python/ruffus: Convert to python3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/ruffus/ruffus.SlackBuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/python/ruffus/ruffus.SlackBuild b/python/ruffus/ruffus.SlackBuild
index 44d77c1859..6f860a3dae 100644
--- a/python/ruffus/ruffus.SlackBuild
+++ b/python/ruffus/ruffus.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ruffus
-# Copyright 2018-2019 Rob van Nues
+# Copyright 2018-2021 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -30,10 +30,6 @@ BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-#set which python version to install it for
-PYTHON2=false
-PYTHON3=true
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -83,12 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if $PYTHON2; then
- python setup.py install --root=$PKG
-fi
-if $PYTHON3; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true