summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dominik Drobek2019-03-17 22:39:15 +0100
committer Willy Sudiarto Raharjo2019-03-20 14:45:59 +0100
commitb73cbb74f680c3074e76fb09aeac9dba374651be (patch)
tree6f68f58351239d013acc3f917420da578cc70779
parent3647060904b229780b12ab484177c741eaaae6dd (diff)
downloadslackbuilds-b73cbb74f680c3074e76fb09aeac9dba374651be.tar.gz
python/GeoIP-Python: enable Python3
Also, move from "libraries" to "python" category. The latter did not exist at the time this SlackBuild was added to SBo. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/GeoIP-Python/GeoIP-Python.SlackBuild (renamed from libraries/GeoIP-Python/GeoIP-Python.SlackBuild)8
-rw-r--r--python/GeoIP-Python/GeoIP-Python.info (renamed from libraries/GeoIP-Python/GeoIP-Python.info)2
-rw-r--r--python/GeoIP-Python/README (renamed from libraries/GeoIP-Python/README)0
-rw-r--r--python/GeoIP-Python/slack-desc (renamed from libraries/GeoIP-Python/slack-desc)0
4 files changed, 7 insertions, 3 deletions
diff --git a/libraries/GeoIP-Python/GeoIP-Python.SlackBuild b/python/GeoIP-Python/GeoIP-Python.SlackBuild
index 46a797207b..5ed58a8443 100644
--- a/libraries/GeoIP-Python/GeoIP-Python.SlackBuild
+++ b/python/GeoIP-Python/GeoIP-Python.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for GeoIP-Python
-# Copyright Dominik Drobek <dominik.drobek (at) o2.pl>
+# Copyright 2011, 2013, 2016, 2019 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=GeoIP-Python
VERSION=${VERSION:-1.3.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
DISTNAME=GeoIP
@@ -74,6 +74,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/GeoIP-Python/GeoIP-Python.info b/python/GeoIP-Python/GeoIP-Python.info
index f4b7e21b3f..b2be73dc60 100644
--- a/libraries/GeoIP-Python/GeoIP-Python.info
+++ b/python/GeoIP-Python/GeoIP-Python.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="GeoIP"
MAINTAINER="Dominik Drobek"
-EMAIL="dominik.drobek@o2.pl"
+EMAIL="dominik.drobek (at) o2.pl"
diff --git a/libraries/GeoIP-Python/README b/python/GeoIP-Python/README
index bd19f393e3..bd19f393e3 100644
--- a/libraries/GeoIP-Python/README
+++ b/python/GeoIP-Python/README
diff --git a/libraries/GeoIP-Python/slack-desc b/python/GeoIP-Python/slack-desc
index 56bf82ffb5..56bf82ffb5 100644
--- a/libraries/GeoIP-Python/slack-desc
+++ b/python/GeoIP-Python/slack-desc