summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2024-05-09 18:00:49 +0200
committer Willy Sudiarto Raharjo2024-05-11 01:51:55 +0200
commitb5cbfd9ce75ce9eb277953e520094611e6860b34 (patch)
tree1a7dfae0eeccec8054b4b8c6f17d47e0f6177e74
parent1eb345e5a6ef90f9c0e2f3181f78e7099e002e38 (diff)
downloadslackbuilds-b5cbfd9ce75ce9eb277953e520094611e6860b34.tar.gz
libraries/folly: Removed (FTBFS).
https://github.com/SlackBuildsOrg/slackbuilds/pull/6162 Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/folly/0001-Fix-CMakeLists.txt-to-honor-CMAKE_INSTALL_LIBDIR.patch30
-rw-r--r--libraries/folly/README6
-rw-r--r--libraries/folly/folly.SlackBuild118
-rw-r--r--libraries/folly/folly.info10
-rw-r--r--libraries/folly/slack-desc19
5 files changed, 0 insertions, 183 deletions
diff --git a/libraries/folly/0001-Fix-CMakeLists.txt-to-honor-CMAKE_INSTALL_LIBDIR.patch b/libraries/folly/0001-Fix-CMakeLists.txt-to-honor-CMAKE_INSTALL_LIBDIR.patch
deleted file mode 100644
index 87c0fa6a25..0000000000
--- a/libraries/folly/0001-Fix-CMakeLists.txt-to-honor-CMAKE_INSTALL_LIBDIR.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 85422b744ae2294d60fdae9074ad8eae53323e66 Mon Sep 17 00:00:00 2001
-From: Ebben Aries <exa@dscp.org>
-Date: Thu, 16 Jun 2022 08:18:06 -0700
-Subject: [PATCH] Fix CMakeLists.txt to honor CMAKE_INSTALL_LIBDIR
-
----
- CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 21d24ba6e..8f83f22c4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -52,11 +52,11 @@ project(${PACKAGE_NAME} CXX C ASM)
-
- set(INCLUDE_INSTALL_DIR include CACHE STRING
- "The subdirectory where header files should be installed")
--set(LIB_INSTALL_DIR lib CACHE STRING
-+set(LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR} CACHE STRING
- "The subdirectory where libraries should be installed")
- set(BIN_INSTALL_DIR bin CACHE STRING
- "The subdirectory where binaries should be installed")
--set(CMAKE_INSTALL_DIR lib/cmake/folly CACHE STRING
-+set(CMAKE_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/folly CACHE STRING
- "The subdirectory where CMake package config files should be installed")
-
- option(BUILD_SHARED_LIBS
---
-2.36.1
-
diff --git a/libraries/folly/README b/libraries/folly/README
deleted file mode 100644
index 9dea6f4127..0000000000
--- a/libraries/folly/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Folly (acronymed loosely after Facebook Open Source Library) is a
-library of C++14 components designed with practicality and efficiency in
-mind. Folly contains a variety of core library components used
-extensively at Facebook. In particular, it's often a dependency of
-Facebook's other open source C++ efforts and place where those projects
-can share code.
diff --git a/libraries/folly/folly.SlackBuild b/libraries/folly/folly.SlackBuild
deleted file mode 100644
index 8b4e80784d..0000000000
--- a/libraries/folly/folly.SlackBuild
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for folly
-
-# Copyright 2022 Ebben Aries <slackbuilds@dscp.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=folly
-VERSION=${VERSION:-20220722_437b29d}
-GITHASH=${GITHASH:-437b29dd062a40c741b2147827025a2f413b76c7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$GITHASH
-mkdir $PRGNAM-$GITHASH
-tar xvf $CWD/$PRGNAM-$GITHASH.tar.gz
-cd $PRGNAM-$GITHASH
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Fix for CMAKE_INSTALL_LIBDIR
-# https://github.com/facebook/folly/pull/1796
-patch -p1 < $CWD/0001-Fix-CMakeLists.txt-to-honor-CMAKE_INSTALL_LIBDIR.patch
-
-mkdir -p _build
-cd _build
- cmake \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc \
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
- -DCMAKE_INSTALL_MANDIR=/usr/man \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=ON \
- ..
-
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-rm -rf $PKG/usr/share/ $PKG/usr/doc/$PRGNAM-$VERSION/NEWS
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-rm -f $PKG/usr/lib*/*.la
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/folly/folly.info b/libraries/folly/folly.info
deleted file mode 100644
index d117806b6c..0000000000
--- a/libraries/folly/folly.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="folly"
-VERSION="20220722_437b29d"
-HOMEPAGE="https://github.com/facebook/folly"
-DOWNLOAD="https://github.com/facebook/folly/archive/437b29d/folly-437b29dd062a40c741b2147827025a2f413b76c7.tar.gz"
-MD5SUM="c4ac1fa2f76c8c8291c5abb3643b3741"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="double-conversion glog gflags fmt"
-MAINTAINER="Ebben Aries"
-EMAIL="slackbuilds@dscp.org"
diff --git a/libraries/folly/slack-desc b/libraries/folly/slack-desc
deleted file mode 100644
index 51dcacc036..0000000000
--- a/libraries/folly/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-folly: folly (Facebook Open-source Library)
-folly:
-folly: Folly is a library of C++14 components designed with practicality and
-folly: efficiency in mind. It complements (as opposed to competing against)
-folly: offerings such as Boost and of course std.
-folly:
-folly:
-folly:
-folly:
-folly: Homepage: https://github.com/facebook/folly
-folly: