summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2021-07-23 22:26:12 +0200
committer Willy Sudiarto Raharjo2021-07-25 11:55:52 +0200
commitb050716e4a99037b59fd24b34181968adf1d880a (patch)
tree2c6484676319a70ee248cbb3e306801c2c5df06b
parent18c93086b5d280195ac3f2f026464cae863fbfe5 (diff)
downloadslackbuilds-b050716e4a99037b59fd24b34181968adf1d880a.tar.gz
python/python2-setuptools-scm: Added (setuptools-scm for Python 2).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-setuptools-scm/README7
-rw-r--r--python/python2-setuptools-scm/python2-setuptools-scm.SlackBuild80
-rw-r--r--python/python2-setuptools-scm/python2-setuptools-scm.info10
-rw-r--r--python/python2-setuptools-scm/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python2-setuptools-scm/README b/python/python2-setuptools-scm/README
new file mode 100644
index 0000000000..ee7c616d65
--- /dev/null
+++ b/python/python2-setuptools-scm/README
@@ -0,0 +1,7 @@
+setuptools_scm handles managing your python package versions in scm
+metadata instead of declaring them as the version argument or in a
+scm managed file.
+
+It also handles file finders for the supported scm's.
+
+This version is compatible with Python 2.
diff --git a/python/python2-setuptools-scm/python2-setuptools-scm.SlackBuild b/python/python2-setuptools-scm/python2-setuptools-scm.SlackBuild
new file mode 100644
index 0000000000..fb3beed942
--- /dev/null
+++ b/python/python2-setuptools-scm/python2-setuptools-scm.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python2-setuptools-scm
+
+# Copyright 2016-2019 Hunter Sezen California, USA
+# Copyright 2021 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-setuptools-scm
+SRCNAM=$(printf %s $PRGNAM | tr - _ | sed 's/^python2_//')
+VERSION=${VERSION:-5.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.rst LICENSE README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-setuptools-scm/python2-setuptools-scm.info b/python/python2-setuptools-scm/python2-setuptools-scm.info
new file mode 100644
index 0000000000..7cde7b9296
--- /dev/null
+++ b/python/python2-setuptools-scm/python2-setuptools-scm.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-setuptools-scm"
+VERSION="5.0.2"
+HOMEPAGE="https://github.com/pypa/setuptools_scm"
+DOWNLOAD="https://files.pythonhosted.org/packages/56/c9/09f4a531720b1bf54f316fdff926fbb937c59a9c4a34e3a533b26e501898/setuptools_scm-5.0.2.tar.gz"
+MD5SUM="8ddd44e0cd3a243350fe709024ec7224"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/python/python2-setuptools-scm/slack-desc b/python/python2-setuptools-scm/slack-desc
new file mode 100644
index 0000000000..38e96a5c1d
--- /dev/null
+++ b/python/python2-setuptools-scm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-setuptools-scm: python2-setuptools-scm (manage versions by scm tags - Python 2)
+python2-setuptools-scm:
+python2-setuptools-scm: setuptools_scm handles managing your python package versions in scm
+python2-setuptools-scm: metadata instead of declaring them as the version argument or in a
+python2-setuptools-scm: scm managed file.
+python2-setuptools-scm:
+python2-setuptools-scm: It also handles file finders for the supported scms.
+python2-setuptools-scm:
+python2-setuptools-scm: Homepage: https://github.com/pypa/setuptools_scm
+python2-setuptools-scm:
+python2-setuptools-scm: