summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Juan M. Lasca2023-02-10 05:24:41 +0100
committer Willy Sudiarto Raharjo2023-02-11 03:30:36 +0100
commitab655c568bd2ae42506c2d907e49fa532fac6092 (patch)
treeb904f646aa8932ced6a81f757a1d9a82022888ce
parent7c333781165763d6221124db37c94b0c47b5369a (diff)
downloadslackbuilds-ab655c568bd2ae42506c2d907e49fa532fac6092.tar.gz
network/gnome-bluetooth: Meson patch.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/gnome-bluetooth/gnome-bluetooth.SlackBuild6
-rw-r--r--network/gnome-bluetooth/patches/01-meson.patch17
2 files changed, 22 insertions, 1 deletions
diff --git a/network/gnome-bluetooth/gnome-bluetooth.SlackBuild b/network/gnome-bluetooth/gnome-bluetooth.SlackBuild
index cab85243ad..d381647dab 100644
--- a/network/gnome-bluetooth/gnome-bluetooth.SlackBuild
+++ b/network/gnome-bluetooth/gnome-bluetooth.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gnome-bluetooth
VERSION=${VERSION:-3.34.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,6 +77,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Special thanks to Bob Funk, who kindly pointed this problem out and
+# provided a link to the patch fixing it.
+cat $CWD/patches/01-meson.patch | patch -p1 || exit
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
diff --git a/network/gnome-bluetooth/patches/01-meson.patch b/network/gnome-bluetooth/patches/01-meson.patch
new file mode 100644
index 0000000000..79c0a08725
--- /dev/null
+++ b/network/gnome-bluetooth/patches/01-meson.patch
@@ -0,0 +1,17 @@
+# 08/02/2023: Allow newer versions of meson to build this package.
+# Special thanks to Bob Funk who kindly pointed this out.
+# Original patch url: https://gitlab.gnome.org/GNOME/gnome-bluetooth/-/commit/755fd758f866d3a3f7ca482942beee749f13a91e.patch
+
+diff --git a/sendto/meson.build b/sendto/meson.build
+index 24a4e394..3e233a03 100644
+--- a/sendto/meson.build
++++ b/sendto/meson.build
+@@ -22,7 +22,6 @@ desktop_in = configure_file(
+ )
+
+ i18n.merge_file (
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: desktop,
+--