summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2021-07-25 08:57:49 +0200
committer Willy Sudiarto Raharjo2021-07-25 11:56:07 +0200
commita5c714b4377d8e55eb6004552194a491dca7586d (patch)
treed3c783d578b17571bfefa104b14f9745644ab8f8
parent5ec56aa1be402f03e693a7a7526868a0f0cd906d (diff)
downloadslackbuilds-a5c714b4377d8e55eb6004552194a491dca7586d.tar.gz
python/python2-pkgconfig: Added (python module for pkg-tool).
This is needed by python2-lz4. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-pkgconfig/README1
-rw-r--r--python/python2-pkgconfig/python2-pkgconfig.SlackBuild98
-rw-r--r--python/python2-pkgconfig/python2-pkgconfig.info10
-rw-r--r--python/python2-pkgconfig/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/python2-pkgconfig/README b/python/python2-pkgconfig/README
new file mode 100644
index 0000000000..b1ad89ebfb
--- /dev/null
+++ b/python/python2-pkgconfig/README
@@ -0,0 +1 @@
+python2-pkgconfig: module to interface with the pkg-config tool
diff --git a/python/python2-pkgconfig/python2-pkgconfig.SlackBuild b/python/python2-pkgconfig/python2-pkgconfig.SlackBuild
new file mode 100644
index 0000000000..0a972dc143
--- /dev/null
+++ b/python/python2-pkgconfig/python2-pkgconfig.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for python2-pkgconfig
+
+# Copyright 2021 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-pkgconfig
+SRCNAM=$(printf %s $PRGNAM | sed 's/^python2-//')
+VERSION=${VERSION:-1.5.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pkgconfig/python2-pkgconfig.info b/python/python2-pkgconfig/python2-pkgconfig.info
new file mode 100644
index 0000000000..e9a6d7ab30
--- /dev/null
+++ b/python/python2-pkgconfig/python2-pkgconfig.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-pkgconfig"
+VERSION="1.5.2"
+HOMEPAGE="https://github.com/matze/pkgconfig"
+DOWNLOAD="https://files.pythonhosted.org/packages/ae/61/5a76ead90f9a62212c231b05231031e750f24e4dd2401d8c7f3f0527821b/pkgconfig-1.5.2.tar.gz"
+MD5SUM="0d889edf670b644bfeaa3bb9444169cb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/python/python2-pkgconfig/slack-desc b/python/python2-pkgconfig/slack-desc
new file mode 100644
index 0000000000..b7568ffc5d
--- /dev/null
+++ b/python/python2-pkgconfig/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pkgconfig: python2-pkgconfig (python interface to pkg-config)
+python2-pkgconfig:
+python2-pkgconfig: pkgconfig is a Python module to interface with the pkg-config command
+python2-pkgconfig: line tool and supports Python 2.6+ and 3.3+.
+python2-pkgconfig:
+python2-pkgconfig: https://github.com/matze/pkgconfig
+python2-pkgconfig:
+python2-pkgconfig:
+python2-pkgconfig:
+python2-pkgconfig:
+python2-pkgconfig: