summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-08-26 21:50:36 +0200
committer Willy Sudiarto Raharjo2022-08-27 17:50:33 +0200
commit8b8b060f46d86d31a8f71d1a356ec56880342ae0 (patch)
tree39643558d2e1bd0e4998b243953b231bb409d891
parent928c1086bd5d73d2f0674f7dd378dc78e027d89d (diff)
downloadslackbuilds-8b8b060f46d86d31a8f71d1a356ec56880342ae0.tar.gz
python/python3-h5py: Added (Python bindings for h5py)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-h5py/README7
-rw-r--r--python/python3-h5py/python3-h5py.SlackBuild101
-rw-r--r--python/python3-h5py/python3-h5py.info10
-rw-r--r--python/python3-h5py/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/python/python3-h5py/README b/python/python3-h5py/README
new file mode 100644
index 0000000000..d5192140f9
--- /dev/null
+++ b/python/python3-h5py/README
@@ -0,0 +1,7 @@
+The h5py package is a Pythonic interface to the HDF5 binary data format.
+
+It lets you store huge amounts of numerical data, and easily manipulate
+that data from NumPy. For example, you can slice into multi-terabyte
+datasets stored on disk as if they were real NumPy arrays. Thousands
+of datasets can be stored in a single file, categorized and tagged
+however you want.
diff --git a/python/python3-h5py/python3-h5py.SlackBuild b/python/python3-h5py/python3-h5py.SlackBuild
new file mode 100644
index 0000000000..20e1bbd1ac
--- /dev/null
+++ b/python/python3-h5py/python3-h5py.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/bash
+
+# Slackware build script for python3-h5py
+
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-h5py
+VERSION=${VERSION:-3.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=h5py
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+# Remove RPATH
+sed -i "s/settings\\['runtime_library_dirs'\\] = settings\\['library_dirs'\\]/pass/" setup_build.py
+
+H5PY_SYSTEM_LZF=1 python3 setup.py build
+python3 setup.py install --root=$PKG --skip-build --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-h5py/python3-h5py.info b/python/python3-h5py/python3-h5py.info
new file mode 100644
index 0000000000..d14e849a52
--- /dev/null
+++ b/python/python3-h5py/python3-h5py.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-h5py"
+VERSION="3.7.0"
+HOMEPAGE="https://www.h5py.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/h/h5py/h5py-3.7.0.tar.gz"
+MD5SUM="acb43ba2b0b853005af71eccfc456676"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="hdf5 liblzf numpy3 python3-pkgconfig"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-h5py/slack-desc b/python/python3-h5py/slack-desc
new file mode 100644
index 0000000000..eb2e11954b
--- /dev/null
+++ b/python/python3-h5py/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-h5py: python3-h5py (Python bindings for h5py)
+python3-h5py:
+python3-h5py: The h5py package is a Pythonic interface to the HDF5 binary data
+python3-h5py: format.
+python3-h5py:
+python3-h5py:
+python3-h5py:
+python3-h5py:
+python3-h5py:
+python3-h5py:
+python3-h5py: