summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author ponce2012-07-25 12:39:24 +0200
committer Robby Workman2012-08-21 15:55:25 +0200
commit63ea1bca9e4cd63bf79eac0f922eba121a030938 (patch)
tree311d7ae22a5fa0f022d4b79a37d193169c0d3443
parent3db421e8af122d38340edb1a74b90d0089d3ab90 (diff)
downloadslackbuilds-63ea1bca9e4cd63bf79eac0f922eba121a030938.tar.gz
office/abiword: Fixed building with gcc >= 4.6 and glib >= 2.31.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--office/abiword/abiword.SlackBuild8
-rw-r--r--office/abiword/patches/abiword-2.8.6-glib-2.31.patch40
2 files changed, 47 insertions, 1 deletions
diff --git a/office/abiword/abiword.SlackBuild b/office/abiword/abiword.SlackBuild
index 1214057dfd..33f1aef690 100644
--- a/office/abiword/abiword.SlackBuild
+++ b/office/abiword/abiword.SlackBuild
@@ -29,7 +29,7 @@
PRGNAM=abiword
VERSION=2.8.6
DOCSVER=$VERSION # version of abiword-docs
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -82,6 +82,12 @@ patch -p1 < $CWD/patches/boost_asio.patch
# This should make the help stuff work properly
patch -p1 < $CWD/patches/url_show.patch
+# This fixes building with gcc-4.7
+sed -i "s|--no-undefined||" src/Makefile.{am,in}
+
+# This fixes building with glib >= 2.31 (thanks to gentoo)
+patch -p0 < $CWD/patches/abiword-2.8.6-glib-2.31.patch
+
CPPFLAGS="-I$TMP/$PRGNAM-$VERSION" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/office/abiword/patches/abiword-2.8.6-glib-2.31.patch b/office/abiword/patches/abiword-2.8.6-glib-2.31.patch
new file mode 100644
index 0000000000..8b938cc25a
--- /dev/null
+++ b/office/abiword/patches/abiword-2.8.6-glib-2.31.patch
@@ -0,0 +1,40 @@
+------------------------------------------------------------------------
+r30479 | hub | 2011-11-29 00:39:09 -0500 (Tue, 29 Nov 2011) | 2 lines
+Changed paths:
+ M /abiword/trunk/src/af/util/xp/ut_go_file.h
+
+Bug 13197: only import glib.h
+Patch by Dominique Leuenberger.
+------------------------------------------------------------------------
+r30602 | hub | 2012-01-30 02:00:38 -0500 (Mon, 30 Jan 2012) | 2 lines
+Changed paths:
+ M /abiword/trunk/goffice-bits/goffice/app/goffice-app.h
+
+Bug 13247 - Fix glib headers. Patch by Funda Wang
+(safe to backport)
+------------------------------------------------------------------------
+Index: src/af/util/xp/ut_go_file.h
+===================================================================
+--- src/af/util/xp/ut_go_file.h (revision 30478)
++++ src/af/util/xp/ut_go_file.h (revision 30479)
+@@ -31,7 +31,6 @@
+
+ #include <glib.h>
+ #include <gsf/gsf.h>
+-#include <glib/gerror.h>
+ #include <time.h>
+
+ G_BEGIN_DECLS
+Index: goffice-bits/goffice/app/goffice-app.h
+===================================================================
+--- goffice-bits/goffice/app/goffice-app.h (revision 30601)
++++ goffice-bits/goffice/app/goffice-app.h (revision 30602)
+@@ -22,7 +22,7 @@
+ #ifndef GOFFICE_APP_H
+ #define GOFFICE_APP_H
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+