summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky2023-06-22 18:11:58 +0200
committer Willy Sudiarto Raharjo2023-06-22 18:12:11 +0200
commit5a03b6defcf24658456f0d1e0aa86dd91aadd61b (patch)
tree8616965f7cc120cfdf7e1cf5d495ac5dd6be62c8
parentb587b4f03416f487215bf54ab2e8bb7f1f5bf02e (diff)
downloadslackbuilds-5a03b6defcf24658456f0d1e0aa86dd91aadd61b.tar.gz
python/python3-PyMuPDF: Added (Python binding for mupdf).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-PyMuPDF/README16
-rw-r--r--python/python3-PyMuPDF/python3-PyMuPDF.SlackBuild79
-rw-r--r--python/python3-PyMuPDF/python3-PyMuPDF.info10
-rw-r--r--python/python3-PyMuPDF/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python3-PyMuPDF/README b/python/python3-PyMuPDF/README
new file mode 100644
index 0000000000..93c234c837
--- /dev/null
+++ b/python/python3-PyMuPDF/README
@@ -0,0 +1,16 @@
+PyMuPDF adds Python bindings and abstractions to MuPDF, a lightweight
+PDF, XPS, and eBook viewer, renderer, and toolkit. Both PyMuPDF and
+MuPDF are maintained and developed by Artifex Software, Inc.
+
+MuPDF can access files in PDF, XPS, OpenXPS, CBZ, EPUB and FB2 (eBooks)
+formats, and it is known for its top performance and exceptional
+rendering quality.
+
+With PyMuPDF you can access files with extensions like .pdf, .xps,
+.oxps, .cbz, .fb2 or .epub. In addition, about 10 popular image formats
+can also be handled like documents: .png, .jpg, .bmp, .tiff, etc.
+
+krop (available on SBo) can use PyMuPDF for both rendering and cropping.
+
+Optional autodetected dependencies are python-fonttools, tesseract,
+Pillow, pymupdf-fonts.
diff --git a/python/python3-PyMuPDF/python3-PyMuPDF.SlackBuild b/python/python3-PyMuPDF/python3-PyMuPDF.SlackBuild
new file mode 100644
index 0000000000..9c5d0f4630
--- /dev/null
+++ b/python/python3-PyMuPDF/python3-PyMuPDF.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/bash
+
+# Slackware build script for python3-PyMuPDF
+
+# Copyright 2023, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-PyMuPDF
+VERSION=${VERSION:-1.21.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${PRGNAM:8}-$VERSION
+tar xvf $CWD/${PRGNAM:8}-$VERSION.tar.gz
+cd ${PRGNAM:8}-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export PYMUPDF_SETUP_MUPDF_BUILD=""
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md changes.txt docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-PyMuPDF/python3-PyMuPDF.info b/python/python3-PyMuPDF/python3-PyMuPDF.info
new file mode 100644
index 0000000000..38cfa37671
--- /dev/null
+++ b/python/python3-PyMuPDF/python3-PyMuPDF.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-PyMuPDF"
+VERSION="1.21.1"
+HOMEPAGE="https://github.com/pymupdf/PyMuPDF"
+DOWNLOAD="https://github.com/pymupdf/PyMuPDF/archive/1.21.1/PyMuPDF-1.21.1.tar.gz"
+MD5SUM="b211e6fa22ceb44d01219d7ede7ec171"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mupdf %README%"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/python/python3-PyMuPDF/slack-desc b/python/python3-PyMuPDF/slack-desc
new file mode 100644
index 0000000000..2521a76799
--- /dev/null
+++ b/python/python3-PyMuPDF/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-PyMuPDF: python3-PyMuPDF (python bindings for mupdf)
+python3-PyMuPDF:
+python3-PyMuPDF:
+python3-PyMuPDF: PyMuPDF adds Python bindings and abstractions to MuPDF, a lightweight
+python3-PyMuPDF: PDF, XPS, and eBook viewer, renderer, and toolkit. Both PyMuPDF and
+python3-PyMuPDF: MuPDF are maintained and developed by Artifex Software, Inc.
+python3-PyMuPDF:
+python3-PyMuPDF: Homepage: https://github.com/pymupdf/PyMuPDF
+python3-PyMuPDF:
+python3-PyMuPDF:
+python3-PyMuPDF: