summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2023-06-06 00:24:03 +0200
committer Willy Sudiarto Raharjo2023-06-10 09:01:23 +0200
commit4e43aa07beb1c2b4300aacc6ff71333f1aff0bb8 (patch)
treeaea01b0d9772794227627468f6040a9a72e49fee
parent41a86e2c850f06387d53475bfab88997d565bc26 (diff)
downloadslackbuilds-4e43aa07beb1c2b4300aacc6ff71333f1aff0bb8.tar.gz
games/desmume: Updated for version 0.9.13, new maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/desmume/README7
-rw-r--r--games/desmume/desmume.SlackBuild71
-rw-r--r--games/desmume/desmume.info12
-rw-r--r--games/desmume/doinst.sh6
4 files changed, 59 insertions, 37 deletions
diff --git a/games/desmume/README b/games/desmume/README
index 2cfa4c89c4..93096732b3 100644
--- a/games/desmume/README
+++ b/games/desmume/README
@@ -1,4 +1,7 @@
-DeSmuME is a Nintendo DS emulator running homebrew demos and
+desmume (Nintendo DS emulator)
+
+DeSmuME is a Nintendo DS emulator running homebrew demos and
commercial games.
-lua is an optional dependency.
+Note: the desmume man page is horribly outdated. See "desmume --help"
+for a complete list of options.
diff --git a/games/desmume/desmume.SlackBuild b/games/desmume/desmume.SlackBuild
index da11d5fcc0..45531361b6 100644
--- a/games/desmume/desmume.SlackBuild
+++ b/games/desmume/desmume.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for desmume
-# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2015 Larry Hajali <email removed>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,31 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230605 bkw:
+# - new maintainer.
+# - update for v0.9.13.
+# - fix typo in .desktop file.
+# - fix doinst.sh.
+# - remove zziplib from REQUIRES (desmume doesn't use it at all).
+# - remove gtkglext from REQUIRES (desmume doesn't use it, even though
+# the README.LIN claims it does).
+# - remove mention of optional lua dep in README, because it's not real
+# (see src/frontend/posix/meson.build; it's commented out).
+
+# Notes:
+
+# agg and soundtouch are actually optional. leave them in REQUIRES for
+# now because I'm not feeling motivated enough to test what happens if
+# you build without them.
+
+# git repo here: https://github.com/TASEmulators/desmume
+# check for updates: https://github.com/TASEmulators/desmume/tags
+# game ROMs here: https://vimm.net/vault/DS (ad-ridden)
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=desmume
-VERSION=${VERSION:-20210409_e8f619c}
+VERSION=${VERSION:-0.9.13}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +59,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,38 +70,31 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
+TARVER="release_$( echo $VERSION | sed 's,\.,_,g' )"
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$TARVER
+tar xvf $CWD/$PRGNAM-$TARVER.tar.gz
+cd $PRGNAM-$TARVER
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# https://github.com/TASVideos/desmume
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
-cd $PRGNAM/src/frontend/posix
-mkdir build
-cd build
+cd $PRGNAM
+mkdir -p src/frontend/posix/build
+cd src/frontend/posix/build
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
meson .. \
@@ -100,15 +111,17 @@ cd build
"${NINJA:=ninja}"
DESTDIR=$PKG $NINJA install
-cd ../../../..
+cd -
+
+# 20230605 bkw: this would drive me insane if I didn't fix it:
+sed -i 's,Nintento,Nintendo,g' $PKG/usr/share/applications/*.desktop
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+gzip -9 $PKG/usr/man/man*/*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING README README.LIN doc/ds*.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a AUTHORS ChangeLog COPYING README README.LIN doc/ds*.txt $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/games/desmume/desmume.info b/games/desmume/desmume.info
index 9043529e4b..46bd5c010a 100644
--- a/games/desmume/desmume.info
+++ b/games/desmume/desmume.info
@@ -1,10 +1,10 @@
PRGNAM="desmume"
-VERSION="20210409_e8f619c"
+VERSION="0.9.13"
HOMEPAGE="http://desmume.org/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/desmume-20210409_e8f619c.tar.xz"
-MD5SUM="b723d4f67ba3831b452d5a27542b4f03"
+DOWNLOAD="https://github.com/TASEmulators/desmume/archive/release_0_9_13/desmume-release_0_9_13.tar.gz"
+MD5SUM="d6c9bb4dd1dcaee9c0a5064663e66658"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="agg gtkglext soundtouch zziplib"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
+REQUIRES="agg soundtouch"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/games/desmume/doinst.sh b/games/desmume/doinst.sh
index 5fb28930db..65c7e2eeb9 100644
--- a/games/desmume/doinst.sh
+++ b/games/desmume/doinst.sh
@@ -1,3 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi