summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-10-12 07:15:40 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:52:43 +0200
commit397bc0cd9bfb2dfcdbfa97523f02f9f02e15add2 (patch)
treeb7168f481ddb776c918e5a41d71b149b6da5d40a
parent8d93bcfabe35a584ae25540ef992a1be84ce0bd9 (diff)
downloadslackbuilds-397bc0cd9bfb2dfcdbfa97523f02f9f02e15add2.tar.gz
games/zdoom: New-style icons, fix -current build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/zdoom/README17
-rw-r--r--games/zdoom/doinst.sh5
-rw-r--r--games/zdoom/icons/128.pngbin0 -> 25576 bytes
-rw-r--r--games/zdoom/icons/16.pngbin0 -> 764 bytes
-rw-r--r--games/zdoom/icons/32.pngbin0 -> 2278 bytes
-rw-r--r--games/zdoom/icons/48.pngbin0 -> 4817 bytes
-rw-r--r--games/zdoom/icons/64.pngbin0 -> 7415 bytes
-rw-r--r--games/zdoom/zdoom.SlackBuild34
-rw-r--r--games/zdoom/zdoom.desktop2
-rw-r--r--games/zdoom/zdoom.pngbin1738 -> 0 bytes
10 files changed, 36 insertions, 22 deletions
diff --git a/games/zdoom/README b/games/zdoom/README
index fe2573a123..ac6ed62d60 100644
--- a/games/zdoom/README
+++ b/games/zdoom/README
@@ -1,9 +1,9 @@
zdoom (an enhanced port of the official DOOM source code)
-ZDoom is a family of enhanced ports of the Doom engine to modern operating
-systems. It runs on Windows, Linux, and OS X, and adds new features not
-found in the games as originally published by id Software. It supports
-Doom, Doom II, Heretic, Hexen, Strife, and more.
+ZDoom is a family of enhanced ports of the Doom engine to modern
+operating systems. It runs on Windows, Linux, and OS X, and adds
+new features not found in the games as originally published by id
+Software. It supports Doom, Doom II, Heretic, Hexen, Strife, and more.
zdoom is only a game engine. To actually play the game, you'll need the
game data (IWAD file) from one or more of the supported games. These
@@ -20,10 +20,11 @@ of these slackbuilds.org packages to get a playable game:
- chexquest3
Optional compile time dependency: openal-soft, used for audio playback
-(as an alternative to fmodapi, which is always built in). It will be
-autodetected at build time. If you want to build zdoom without openal-soft,
-set OPENAL=no in the script's environment. There have been reports that
-various mods work better with OpenAL, while others crash or misbehave; YMMV.
+(as an alternative to fmodapi, which is always built in). It will
+be autodetected at build time. If you want to build zdoom without
+openal-soft, set OPENAL=no in the script's environment. There have
+been reports that various mods work better with OpenAL, while others
+crash or misbehave; YMMV.
Optional runtime dependencies: fluid-soundfont, and/or TiMidity++ and
eawpats (used for MIDI playback). MIDI playback is still possible when
diff --git a/games/zdoom/doinst.sh b/games/zdoom/doinst.sh
index 4e8ba7071d..3e5691a052 100644
--- a/games/zdoom/doinst.sh
+++ b/games/zdoom/doinst.sh
@@ -2,3 +2,8 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/zdoom/icons/128.png b/games/zdoom/icons/128.png
new file mode 100644
index 0000000000..89a571b8fe
--- /dev/null
+++ b/games/zdoom/icons/128.png
Binary files differ
diff --git a/games/zdoom/icons/16.png b/games/zdoom/icons/16.png
new file mode 100644
index 0000000000..3d99a2e834
--- /dev/null
+++ b/games/zdoom/icons/16.png
Binary files differ
diff --git a/games/zdoom/icons/32.png b/games/zdoom/icons/32.png
new file mode 100644
index 0000000000..36a50547aa
--- /dev/null
+++ b/games/zdoom/icons/32.png
Binary files differ
diff --git a/games/zdoom/icons/48.png b/games/zdoom/icons/48.png
new file mode 100644
index 0000000000..ec5e96ff50
--- /dev/null
+++ b/games/zdoom/icons/48.png
Binary files differ
diff --git a/games/zdoom/icons/64.png b/games/zdoom/icons/64.png
new file mode 100644
index 0000000000..e6e3434e45
--- /dev/null
+++ b/games/zdoom/icons/64.png
Binary files differ
diff --git a/games/zdoom/zdoom.SlackBuild b/games/zdoom/zdoom.SlackBuild
index e6278dbd67..443ff986ab 100644
--- a/games/zdoom/zdoom.SlackBuild
+++ b/games/zdoom/zdoom.SlackBuild
@@ -8,6 +8,10 @@
# version had no license, modified version released under the WTFPL,
# see http://www.wtfpl.net/txt/copying/ for details.
+# 20211012 bkw: BUILD=2
+# - Fix -current build.
+# - New-style icons.
+
# 20170207 bkw:
# - Take over maintenance, update for v2.8.1, BUILD=1. Upstream
# says zdoom development has halted, so 2.8.1 should be the last
@@ -41,7 +45,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zdoom
VERSION=${VERSION:-2.8.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -53,9 +57,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -117,14 +118,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-
-# Slight template deviation: I used \+ rather than \; (same result, but maybe
-# 40x faster).
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# gitinfo.h made like so:
## git clone https://github.com/rheit/zdoom.git
@@ -145,6 +140,10 @@ sed -i \
"s,setPluginPath(progdir),setPluginPath(\"/usr/lib$LIBDIRSUFFIX/$PRGNAM\")," \
src/sound/fmodsound.cpp
+# silly gcc version detection assumes the major version will always be
+# only one digit, this broke when we got gcc 10.
+sed -i '/REGEX *MATCH/s,\[3-9\],[1-9][0-9]*,g' game-music-emu/CMakeLists.txt
+
mkdir release
cd release
@@ -162,6 +161,7 @@ mkdir -p \
$PKG/usr/games \
$PKG/usr/share/applications \
$PKG/usr/share/pixmaps \
+ $PKG/usr/share/icons/hicolor/48x48/apps \
$PKG/usr/share/games/doom \
$PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM
@@ -171,9 +171,17 @@ install -s -m755 $PRGNAM $PKG/usr/games
[ -e liboutput_sdl.so ] && \
install -s -m755 liboutput_sdl.so $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM
install -m644 $PRGNAM.pk3 $PKG/usr/share/games/doom/
-install -m644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/
install -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/
+for i in $CWD/icons/*.png; do
+ px=$( basename $i | cut -d. -f1 )
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ cat $i > $dir/$PRGNAM.png
+done
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
cd ..
# Get rid of CRLF endings in the docs.
diff --git a/games/zdoom/zdoom.desktop b/games/zdoom/zdoom.desktop
index 5e4a383a80..265fed75f8 100644
--- a/games/zdoom/zdoom.desktop
+++ b/games/zdoom/zdoom.desktop
@@ -3,6 +3,6 @@ Type=Application
Name=ZDoom
GenericName=Enhanced Doom Engine
Icon=zdoom
-Exec=zdoom %F
+Exec=/usr/games/zdoom %F
Terminal=false
Categories=Game;ActionGame;
diff --git a/games/zdoom/zdoom.png b/games/zdoom/zdoom.png
deleted file mode 100644
index 22f9f49f90..0000000000
--- a/games/zdoom/zdoom.png
+++ /dev/null
Binary files differ