summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-05-25 20:22:48 +0200
committer Willy Sudiarto Raharjo2022-06-04 05:37:16 +0200
commit185d76c39ebad65ca509c6e3c07ff945099fb8a4 (patch)
tree92c5f0bf925ee0b46552a359268b78d4aafd7507
parent0cedd8293c132a0a76a3f686430f1a0ded06df67 (diff)
downloadslackbuilds-185d76c39ebad65ca509c6e3c07ff945099fb8a4.tar.gz
python/testpath: Update for 0.6.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/testpath/testpath.SlackBuild17
-rw-r--r--python/testpath/testpath.info6
2 files changed, 17 insertions, 6 deletions
diff --git a/python/testpath/testpath.SlackBuild b/python/testpath/testpath.SlackBuild
index abb2a10f6c..ac91554187 100644
--- a/python/testpath/testpath.SlackBuild
+++ b/python/testpath/testpath.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=testpath
-VERSION=${VERSION:-0.5.0}
+VERSION=${VERSION:-0.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,14 +80,25 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from distutils.core import setup
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=['${PRGNAM}'],
+ package_data={'': ['*']})
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE PKG-INFO README.rst doc/ \
+ LICENSE PKG-INFO README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/testpath/testpath.info b/python/testpath/testpath.info
index 891df853b3..3d601727e5 100644
--- a/python/testpath/testpath.info
+++ b/python/testpath/testpath.info
@@ -1,8 +1,8 @@
PRGNAM="testpath"
-VERSION="0.5.0"
+VERSION="0.6.0"
HOMEPAGE="https://github.com/jupyter/testpath"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/testpath/testpath-0.5.0.tar.gz"
-MD5SUM="b3a41d75aadeab905f7014a3189e852b"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/testpath/testpath-0.6.0.tar.gz"
+MD5SUM="9fd4339f76da12d15bc718e4aa2566e9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""