summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall2021-05-06 18:11:13 +0200
committer Willy Sudiarto Raharjo2021-05-07 20:41:47 +0200
commit15c2896b99888c51880334dfebd58468328929e4 (patch)
tree31d2589b73f41caea65212286aaa3019dc439896
parent2736c86213709c55205311ac6b56905d1315b6db (diff)
downloadslackbuilds-15c2896b99888c51880334dfebd58468328929e4.tar.gz
python/python-daemon: Renamed python2-daemon.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-daemon/slack-desc19
-rw-r--r--python/python2-daemon/README (renamed from python/python-daemon/README)0
-rw-r--r--python/python2-daemon/python2-daemon.SlackBuild (renamed from python/python-daemon/python-daemon.SlackBuild)17
-rw-r--r--python/python2-daemon/python2-daemon.info (renamed from python/python-daemon/python-daemon.info)2
-rw-r--r--python/python2-daemon/slack-desc19
5 files changed, 29 insertions, 28 deletions
diff --git a/python/python-daemon/slack-desc b/python/python-daemon/slack-desc
deleted file mode 100644
index b2c20d6a6f..0000000000
--- a/python/python-daemon/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-daemon: python-daemon (python library to create pythonic daemon processes)
-python-daemon:
-python-daemon: This library implements the well-behaved daemon specification of
-python-daemon: PEP 3143, "Standard daemon process library".
-python-daemon:
-python-daemon: A well-behaved Unix daemon process is tricky to get right, but
-python-daemon: the required steps are much the same for every daemon program. A
-python-daemon: DaemonContext instance holds the behaviour and configured process
-python-daemon: environment for the program; use the instance as a context manager
-python-daemon: to enter a daemon state.
-python-daemon:
diff --git a/python/python-daemon/README b/python/python2-daemon/README
index e67a64ede3..e67a64ede3 100644
--- a/python/python-daemon/README
+++ b/python/python2-daemon/README
diff --git a/python/python-daemon/python-daemon.SlackBuild b/python/python2-daemon/python2-daemon.SlackBuild
index d40894b658..eb3fb22aeb 100644
--- a/python/python-daemon/python-daemon.SlackBuild
+++ b/python/python2-daemon/python2-daemon.SlackBuild
@@ -10,14 +10,15 @@
# notice and this notice are preserved. This file is offered as-is,
# without any warranty.
-PRGNAM=python-daemon
+PRGNAM=python2-daemon
+SRCNAM=python-daemon
VERSION=${VERSION:-1.5.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -28,8 +29,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -47,9 +48,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -57,7 +58,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-daemon/python-daemon.info b/python/python2-daemon/python2-daemon.info
index 3f084ca23f..a8a5661f16 100644
--- a/python/python-daemon/python-daemon.info
+++ b/python/python2-daemon/python2-daemon.info
@@ -1,4 +1,4 @@
-PRGNAM="python-daemon"
+PRGNAM="python2-daemon"
VERSION="1.5.5"
HOMEPAGE="https://pypi.python.org/pypi/python-daemon/"
DOWNLOAD="https://pypi.python.org/packages/source/p/python-daemon/python-daemon-1.5.5.tar.gz"
diff --git a/python/python2-daemon/slack-desc b/python/python2-daemon/slack-desc
new file mode 100644
index 0000000000..46c02bd380
--- /dev/null
+++ b/python/python2-daemon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-daemon: python2-daemon (python library to create pythonic daemon processes)
+python2-daemon:
+python2-daemon: This library implements the well-behaved daemon specification of
+python2-daemon: PEP 3143, "Standard daemon process library".
+python2-daemon:
+python2-daemon: A well-behaved Unix daemon process is tricky to get right, but
+python2-daemon: the required steps are much the same for every daemon program. A
+python2-daemon: DaemonContext instance holds the behaviour and configured process
+python2-daemon: environment for the program; use the instance as a context manager
+python2-daemon: to enter a daemon state.
+python2-daemon: