summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Yth - Arnaud2023-07-08 03:51:18 +0200
committer Willy Sudiarto Raharjo2023-07-08 03:51:18 +0200
commit1279d69c531124217dcece2123834f6f68ec2dbb (patch)
treeb91781dfffafec31c98a50e2b1db39b2644367c1
parent6b55f3f69212bc7da4cc7a45ce0f4346dbbbd9e8 (diff)
downloadslackbuilds-1279d69c531124217dcece2123834f6f68ec2dbb.tar.gz
python/python3-ZODB: Added (Python object-oriented database).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-ZODB/README15
-rw-r--r--python/python3-ZODB/python3-ZODB.SlackBuild78
-rw-r--r--python/python3-ZODB/python3-ZODB.info10
-rw-r--r--python/python3-ZODB/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/python3-ZODB/README b/python/python3-ZODB/README
new file mode 100644
index 0000000000..ef505fbbb6
--- /dev/null
+++ b/python/python3-ZODB/README
@@ -0,0 +1,15 @@
+ZODB: a Python object-oriented database
+
+ZODB provides an object-oriented database for Python that provides a
+high-degree of transparency. ZODB runs on Python 2.7 or Python 3.4 and
+above. It also runs on PyPy.
+
+- no separate language for database operations
+- very little impact on your code to make objects persistent
+- no database mapper that partially hides the database.
+ Using an object-relational mapping **is not** like using an
+ object-oriented database.
+- almost no seam between code and database.
+ZODB is an ACID Transactional database.
+
+To learn more, visit: https://zodb-docs.readthedocs.io
diff --git a/python/python3-ZODB/python3-ZODB.SlackBuild b/python/python3-ZODB/python3-ZODB.SlackBuild
new file mode 100644
index 0000000000..dca1c82d96
--- /dev/null
+++ b/python/python3-ZODB/python3-ZODB.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/bash
+
+# Slackware build script for python3-ZODB
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-ZODB
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-5.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-ZODB/python3-ZODB.info b/python/python3-ZODB/python3-ZODB.info
new file mode 100644
index 0000000000..eb2eff9d59
--- /dev/null
+++ b/python/python3-ZODB/python3-ZODB.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-ZODB"
+VERSION="5.8.0"
+HOMEPAGE="http://www.zodb.org"
+DOWNLOAD="https://pypi.python.org/packages/source/Z/ZODB/ZODB-5.8.0.tar.gz"
+MD5SUM="233a6ada056ad02c96f7d5ea3faf9909"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-BTrees python3-transaction python3-zc.lockfile python3-ZConfig python3-zodbpickle"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-ZODB/slack-desc b/python/python3-ZODB/slack-desc
new file mode 100644
index 0000000000..e27335f0a8
--- /dev/null
+++ b/python/python3-ZODB/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-ZODB: python3-ZODB (ZODB, a Python object-oriented database)
+python3-ZODB:
+python3-ZODB: ZODB provides an object-oriented database for Python that provides a
+python3-ZODB: high-degree of transparency.
+python3-ZODB: - no separate language for database operations
+python3-ZODB: - very little impact on your code to make objects persistent
+python3-ZODB: - no database mapper that partially hides the database.
+python3-ZODB: - almost no seam between code and database.
+python3-ZODB: ZODB is an ACID Transactional database.
+python3-ZODB:
+python3-ZODB: https://zodb-docs.readthedocs.io