summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author isaackwy2024-01-03 01:20:29 +0100
committer Willy Sudiarto Raharjo2024-01-03 03:47:21 +0100
commit030e91ef86d879e6645b50689651a1f6b9ca85ba (patch)
tree48d406c292b1dfc35c296b2713279321ccde1436
parentca28f758487b45777257432e477ea4c52e5ede08 (diff)
downloadslackbuilds-030e91ef86d879e6645b50689651a1f6b9ca85ba.tar.gz
system/lxqt-config: Add lxqt-menu-data dependency
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/lxqt-config/lxqt-config.SlackBuild6
-rw-r--r--system/lxqt-config/lxqt-config.info2
-rw-r--r--system/lxqt-config/use-lxqt-menu-data-files.patch32
3 files changed, 38 insertions, 2 deletions
diff --git a/system/lxqt-config/lxqt-config.SlackBuild b/system/lxqt-config/lxqt-config.SlackBuild
index f80384b3b4..2427723de0 100644
--- a/system/lxqt-config/lxqt-config.SlackBuild
+++ b/system/lxqt-config/lxqt-config.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lxqt-config
VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# This patch prevents conflicts with lxqt-menu-data
+# It also explicitly sets the lxqt-menu-data requirement
+patch -p1 < $CWD/use-lxqt-menu-data-files.patch
+
mkdir build
cd build
cmake \
diff --git a/system/lxqt-config/lxqt-config.info b/system/lxqt-config/lxqt-config.info
index 455e5147d8..bd5b658055 100644
--- a/system/lxqt-config/lxqt-config.info
+++ b/system/lxqt-config/lxqt-config.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/lxqt/lxqt-config/releases/download/1.3.0/lxqt-confi
MD5SUM="c925164e691dd8da4f44511f42ef5b4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="liblxqt lxqt-themes"
+REQUIRES="liblxqt lxqt-menu-data lxqt-themes"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"
diff --git a/system/lxqt-config/use-lxqt-menu-data-files.patch b/system/lxqt-config/use-lxqt-menu-data-files.patch
new file mode 100644
index 0000000000..e19aa64bb7
--- /dev/null
+++ b/system/lxqt-config/use-lxqt-menu-data-files.patch
@@ -0,0 +1,32 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,6 +36,7 @@
+ find_package(Qt5X11Extras ${QT_MINIMUM_VERSION} REQUIRED)
+ find_package(Qt5Xml ${QT_MINIMUM_VERSION} REQUIRED)
+ find_package(lxqt ${LXQT_MINIMUM_VERSION} REQUIRED)
++find_package(lxqt-menu-data 1.4.1 REQUIRED)
+
+ include(LXQtPreventInSourceBuilds)
+ include(LXQtCompilerSettings NO_POLICY_SCOPE)
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -65,7 +65,3 @@
+ DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/applications"
+ COMPONENT Runtime
+ )
+-install(FILES lxqt-config.menu
+- DESTINATION "${LXQT_ETC_XDG_DIR}/menus"
+- COMPONENT Runtime
+-)
+--- a/src/menuname/CMakeLists.txt
++++ b/src/menuname/CMakeLists.txt
+@@ -8,9 +8,3 @@
+ )
+ add_custom_target(desktop_directories_files ALL DEPENDS ${DIRECTORY_FILES})
+ #************************************************
+-
+-install(FILES
+- ${DIRECTORY_FILES}
+- DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/desktop-directories"
+- COMPONENT Runtime
+-)