summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-05-16 17:51:21 +0200
committer Matteo Bernardini2024-05-25 07:25:45 +0200
commit136136539e22c4997addf17ad3aa40d6ae588729 (patch)
tree5849d9616ff1e476a703fc5c238486ecb789077f
parentbecba3971a51ea467b5e557a19138ec49f667eed (diff)
downloadslackbuilds-rapidjson.tar.gz
libraries/rapidjson: Patch for gcc >= 14.x.rapidjson
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--libraries/rapidjson/gcc14.patch22
-rw-r--r--libraries/rapidjson/rapidjson.SlackBuild2
2 files changed, 24 insertions, 0 deletions
diff --git a/libraries/rapidjson/gcc14.patch b/libraries/rapidjson/gcc14.patch
new file mode 100644
index 0000000000..0799d22aa0
--- /dev/null
+++ b/libraries/rapidjson/gcc14.patch
@@ -0,0 +1,22 @@
+From 3b2441b87f99ab65f37b141a7b548ebadb607b96 Mon Sep 17 00:00:00 2001
+From: Janusz Chorko <janusz.chorko@apdu.pl>
+Date: Fri, 26 Aug 2016 21:17:38 +0200
+Subject: [PATCH] Removed non-compiling assignment operator. Fixed #718
+
+---
+ include/rapidjson/document.h | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/include/rapidjson/document.h b/include/rapidjson/document.h
+index e3e20dfbd..b0f1f70be 100644
+--- a/include/rapidjson/document.h
++++ b/include/rapidjson/document.h
+@@ -316,8 +316,6 @@ struct GenericStringRef {
+
+ GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
+
+- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
+-
+ //! implicit conversion to plain CharType pointer
+ operator const Ch *() const { return s; }
+
diff --git a/libraries/rapidjson/rapidjson.SlackBuild b/libraries/rapidjson/rapidjson.SlackBuild
index 029cf9421d..96dfa719b8 100644
--- a/libraries/rapidjson/rapidjson.SlackBuild
+++ b/libraries/rapidjson/rapidjson.SlackBuild
@@ -86,6 +86,8 @@ find -L . \
# Fix for gcc7+
find -name CMakeLists.txt -exec sed -i 's/ -Werror//g' {} +
+# Fix for gcc14+
+patch -p1 < $CWD/gcc14.patch
mkdir -p build
cd build