summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-09-02 15:19:31 +0200
committer Matteo Bernardini2024-04-27 10:49:27 +0200
commitce01bded64f317809fcb06a8cd3d6c3292eeee69 (patch)
treef09f7d56693b57302855bea42144d2207f8be9e6
parent68ac93024440c1dcb61e579018ce241a1ab44180 (diff)
downloadslackbuilds-python3-glad.tar.gz
python/python3-glad: Removed (added to Slackware).python3-glad
...as python-glad2 Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python3-glad/README5
-rw-r--r--python/python3-glad/python3-glad.SlackBuild79
-rw-r--r--python/python3-glad/python3-glad.info10
-rw-r--r--python/python3-glad/slack-desc19
4 files changed, 0 insertions, 113 deletions
diff --git a/python/python3-glad/README b/python/python3-glad/README
deleted file mode 100644
index 0dd3f36200..0000000000
--- a/python/python3-glad/README
+++ /dev/null
@@ -1,5 +0,0 @@
-python3-glad (Python binding for GLAD Loader-Generator)
-
-GLAD is a Vulkan/GL/GLES/EGL/GLX/WGL Loader-Generator
-based on the official specifications for multiple languages.
-
diff --git a/python/python3-glad/python3-glad.SlackBuild b/python/python3-glad/python3-glad.SlackBuild
deleted file mode 100644
index c6767c5529..0000000000
--- a/python/python3-glad/python3-glad.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-glad
-
-# Copyright 2023 Christoph Willing Brisbane, Australia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-glad
-SRCNAM=glad
-VERSION=${VERSION:-2.0.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-glad/python3-glad.info b/python/python3-glad/python3-glad.info
deleted file mode 100644
index 4ead3d437b..0000000000
--- a/python/python3-glad/python3-glad.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-glad"
-VERSION="2.0.4"
-HOMEPAGE="https://github.com/Dav1dde/glad"
-DOWNLOAD="https://github.com/Dav1dde/glad/archive/v2.0.4/glad-2.0.4.tar.gz"
-MD5SUM="154151c79dab047b26db52fe0572a409"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Christoph Willling"
-EMAIL="chris.willing@linux.com"
diff --git a/python/python3-glad/slack-desc b/python/python3-glad/slack-desc
deleted file mode 100644
index 459c4a5157..0000000000
--- a/python/python3-glad/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-glad: python3-glad (Python binding for GLAD Loader-Generator)
-python3-glad:
-python3-glad: GLAD is a Vulkan/GL/GLES/EGL/GLX/WGL Loader-Generator
-python3-glad: based on the official specifications for multiple languages.
-python3-glad:
-python3-glad:
-python3-glad:
-python3-glad:
-python3-glad:
-python3-glad:
-python3-glad: