summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-01-27 14:20:27 +0100
committer Matteo Bernardini2024-04-20 17:26:34 +0200
commita4adbd00bc171274743acc140b7718c7c33add66 (patch)
tree7ff3a93ceac432f1af00960cbcf3accbfe498038
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-html5lib.tar.gz
libraries/html5lib: Removed (added to Slackware).html5lib
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--libraries/html5lib/README5
-rw-r--r--libraries/html5lib/html5lib.SlackBuild83
-rw-r--r--libraries/html5lib/html5lib.info10
-rw-r--r--libraries/html5lib/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/libraries/html5lib/README b/libraries/html5lib/README
deleted file mode 100644
index 7e57438059..0000000000
--- a/libraries/html5lib/README
+++ /dev/null
@@ -1,5 +0,0 @@
-html5lib is a pure-python library for parsing HTML. It is designed to
-conform to the WHATWG HTML specification, as is implemented by all
-major web browsers.
-
-Optional dependencies: genshi and lxml
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
deleted file mode 100644
index fa754e8b25..0000000000
--- a/libraries/html5lib/html5lib.SlackBuild
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for html5lib
-
-# Copyright 2023 Steven Voges <Oregon, USA>
-# Copyright 2017-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
-# Written by Šime Ramov <s@ramov.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=html5lib
-VERSION=${VERSION:-1.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- *.rst LICENSE PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/html5lib/html5lib.info b/libraries/html5lib/html5lib.info
deleted file mode 100644
index 2640ea6836..0000000000
--- a/libraries/html5lib/html5lib.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="html5lib"
-VERSION="1.1"
-HOMEPAGE="https://github.com/html5lib/html5lib-python"
-DOWNLOAD="https://files.pythonhosted.org/packages/ac/b6/b55c3f49042f1df3dcd422b7f224f939892ee94f22abcf503a9b7339eaf2/html5lib-1.1.tar.gz"
-MD5SUM="6748742e2ec4cb99287a6bc82bcfe2b0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-webencodings"
-MAINTAINER="Steven Voges"
-EMAIL="svoges.sbo@gmail.com"
diff --git a/libraries/html5lib/slack-desc b/libraries/html5lib/slack-desc
deleted file mode 100644
index e4a55d3a1d..0000000000
--- a/libraries/html5lib/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-html5lib: html5lib (HTML parser based on the HTML5 specification)
-html5lib:
-html5lib: Standards-compliant library for parsing and serializing HTML documents
-html5lib: and fragments in Python
-html5lib:
-html5lib: Homepage: https://github.com/html5lib/html5lib-python
-html5lib:
-html5lib:
-html5lib:
-html5lib:
-html5lib: