summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-05-17 10:23:46 +0200
committer Matteo Bernardini2024-05-25 07:13:07 +0200
commit9bb52c59ac90e1e82ad4c8cd932c95146f8da372 (patch)
tree821947d2b478966b2bed4046576c48edd047d663
parentbecba3971a51ea467b5e557a19138ec49f667eed (diff)
downloadslackbuilds-gnome-vfs.tar.gz
system/gnome-vfs: Patched for gcc >= 14.x.gnome-vfs
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--system/gnome-vfs/gnome-vfs.SlackBuild2
-rw-r--r--system/gnome-vfs/patches/gnome-vfs-2.8.2-browser_default.patch20
-rw-r--r--system/gnome-vfs/patches/gnome-vfs2-c99.patch16
-rw-r--r--system/gnome-vfs/patches/gnome-vfs2-configure-c99.patch21
-rw-r--r--system/gnome-vfs/patches/openssl-1.1.patch (renamed from system/gnome-vfs/openssl-1.1.patch)4
5 files changed, 60 insertions, 3 deletions
diff --git a/system/gnome-vfs/gnome-vfs.SlackBuild b/system/gnome-vfs/gnome-vfs.SlackBuild
index c30e90ed9b..2f145faf48 100644
--- a/system/gnome-vfs/gnome-vfs.SlackBuild
+++ b/system/gnome-vfs/gnome-vfs.SlackBuild
@@ -79,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch -p0 < $CWD/openssl-1.1.patch
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
# Fix for the newer glib
sed -i "/-DG_DISABLE_DEPRECATED/d" */Makefile.*
diff --git a/system/gnome-vfs/patches/gnome-vfs-2.8.2-browser_default.patch b/system/gnome-vfs/patches/gnome-vfs-2.8.2-browser_default.patch
new file mode 100644
index 0000000000..438a89de6e
--- /dev/null
+++ b/system/gnome-vfs/patches/gnome-vfs-2.8.2-browser_default.patch
@@ -0,0 +1,20 @@
+--- gnome-vfs-2.8.2/schemas/desktop_gnome_url_handlers.schemas.in.browser_default 2004-10-18 21:38:08.605885937 -0400
++++ gnome-vfs-2.8.2/schemas/desktop_gnome_url_handlers.schemas.in 2004-10-18 21:38:20.470253994 -0400
+@@ -153,7 +153,7 @@
+ <applyto>/desktop/gnome/url-handlers/http/command</applyto>
+ <owner>gnome</owner>
+ <type>string</type>
+- <default>epiphany %s</default>
++ <default>gio open %s</default>
+ <locale name="C">
+ <short>The handler for "http" URLs</short>
+ <long>The command used to handle "http" URLs, if enabled.</long>
+@@ -187,7 +187,7 @@
+ <applyto>/desktop/gnome/url-handlers/https/command</applyto>
+ <owner>gnome</owner>
+ <type>string</type>
+- <default>epiphany %s</default>
++ <default>gio open %s</default>
+ <locale name="C">
+ <short>The handler for "https" URLs</short>
+ <long>The command used to handle "https" URLs, if enabled.</long>
diff --git a/system/gnome-vfs/patches/gnome-vfs2-c99.patch b/system/gnome-vfs/patches/gnome-vfs2-c99.patch
new file mode 100644
index 0000000000..a8b9b5d416
--- /dev/null
+++ b/system/gnome-vfs/patches/gnome-vfs2-c99.patch
@@ -0,0 +1,16 @@
+Include <glib/gprintf.h> for the g_printf function. This avoids an
+implicit function declaration and build failures with future
+compilers.
+
+diff --git a/test/test-async-directory.c b/test/test-async-directory.c
+index 2698d8e6e41f9ead..8d7e0f320edbb5fc 100644
+--- a/test/test-async-directory.c
++++ b/test/test-async-directory.c
+@@ -24,6 +24,7 @@
+ #include <config.h>
+
+ #include <glib.h>
++#include <glib/gprintf.h>
+ #include <libgnomevfs/gnome-vfs-async-ops.h>
+ #include <libgnomevfs/gnome-vfs-init.h>
+ #include <stdio.h>
diff --git a/system/gnome-vfs/patches/gnome-vfs2-configure-c99.patch b/system/gnome-vfs/patches/gnome-vfs2-configure-c99.patch
new file mode 100644
index 0000000000..829c31f0c6
--- /dev/null
+++ b/system/gnome-vfs/patches/gnome-vfs2-configure-c99.patch
@@ -0,0 +1,21 @@
+Avoid an implicit int and an implicit declaration of exit. This
+prevents build failures with future compilers.
+
+diff --git a/configure.in b/configure.in
+index 1a0ad1be03f9f9fe..011c1d919885536a 100644
+--- a/configure.in
++++ b/configure.in
+@@ -366,11 +366,11 @@ AC_TRY_RUN([
+
+ struct linger li;
+
+-main ()
++int main (void)
+ {
+ li.l_onoff = 1;
+ li.l_linger = 120;
+- exit (0);
++ return 0;
+ }
+ ],[
+ AC_DEFINE(HAVE_STRUCT_LINGER, 1, [Define to 1 if struct linger is available])
diff --git a/system/gnome-vfs/openssl-1.1.patch b/system/gnome-vfs/patches/openssl-1.1.patch
index 14207f28d1..3ed1d5edad 100644
--- a/system/gnome-vfs/openssl-1.1.patch
+++ b/system/gnome-vfs/patches/openssl-1.1.patch
@@ -4,8 +4,8 @@ struct SSL is opaque in openssl-1.1; and the SSL_free() man page
says that one should not free members of it manually (in both
the openssl-1.0 and openssl-1.1 man pages).
---- libgnomevfs/gnome-vfs-ssl.c.orig 2010-02-09 12:16:14.000000000 +0000
-+++ libgnomevfs/gnome-vfs-ssl.c
+--- ./libgnomevfs/gnome-vfs-ssl.c.orig 2010-02-09 12:16:14.000000000 +0000
++++ ./libgnomevfs/gnome-vfs-ssl.c
@@ -400,9 +400,6 @@ gnome_vfs_ssl_create_from_fd (GnomeVFSSS
}
}