summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2024-04-13 18:04:43 +0200
committer Matteo Bernardini2024-04-20 17:23:35 +0200
commitbf000bcde6dc6b1254fdb75c3cf018d4a57f1b82 (patch)
tree7da7b40b277821e71d137aefba1fd3a608ce6d48
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-fcitx5.tar.gz
misc/fcitx5: Removed (added to Slackware).fcitx5
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--misc/fcitx5/README37
-rw-r--r--misc/fcitx5/doinst.sh13
-rw-r--r--misc/fcitx5/fcitx5-autostart36
-rw-r--r--misc/fcitx5/fcitx5.SlackBuild110
-rw-r--r--misc/fcitx5/fcitx5.info10
-rw-r--r--misc/fcitx5/slack-desc19
6 files changed, 0 insertions, 225 deletions
diff --git a/misc/fcitx5/README b/misc/fcitx5/README
deleted file mode 100644
index bd043ee147..0000000000
--- a/misc/fcitx5/README
+++ /dev/null
@@ -1,37 +0,0 @@
-Fcitx is an input method framework with extension support. Currently it
-supports Linux and Unix systems like freebsd. Fcitx supports typing
-with many languages all over the world with a large number of engines.
-
-Fcitx has a slim core while provides powerful features with addons. It
-is easy to customize fcitx to satisfy your own needs.
-
-Fcitx5 is the next generation of fcitx.
-
-Some cmake options to keep in mind before building are:
-
-- ENABLE_WAYLAND: Wayland support. Defaults to On and should be fine
- for desktop environments such as KDE and GNOME. Users running
- X11-based window managers will need to turn it off.
-
-- ENABLE_ENCHANT: Enchant support. Defaults to On. Used for word
- prediction (hinting). Depends on libenchant, which is provided by
- most distributions.
-
-The user is encouraged to check the contents of CMakeLists.txt for an
-exhaustive list of options.
-
-For example, an i3 user who wishes to install it to /opt would run
-(likely with sudo privileges):
-
- cmake -DENABLE_WAYLAND=Off \
- -DCMAKE_INSTALL_PREFIX=/your/install/path .
- make
- sudo make install
-
-To make fcitx5 the default input method, please add these lines to your
-/etc/environment (or .profile):
-
- GTK_IM_MODULE=fcitx
- QT_IM_MODULE=fcitx
- XMODIFIERS=@im=fcitx
-
diff --git a/misc/fcitx5/doinst.sh b/misc/fcitx5/doinst.sh
deleted file mode 100644
index 138e27de17..0000000000
--- a/misc/fcitx5/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
diff --git a/misc/fcitx5/fcitx5-autostart b/misc/fcitx5/fcitx5-autostart
deleted file mode 100644
index 22d8c056d3..0000000000
--- a/misc/fcitx5/fcitx5-autostart
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/bash
-
-START="no"
-
-if [ "$XIM" = "fcitx" ]; then
- START="yes"
-fi
-
-if [ "$XIM_PROGRAM" = "fcitx" ]; then
- START="yes"
-fi
-
-if [ "$GTK_IM_MODULE" = "fcitx" ]; then
- START="yes"
-fi
-
-if [ "$QT_IM_MODULE" = "fcitx" ]; then
- START="yes"
-fi
-
-if [ "$START" = "no" ]; then
- exit 0
-fi
-
-# sleep for a little while to avoid duplicate startup
-sleep 2
-
-# Test whether fcitx is running correctly with dbus...
-fcitx5-remote > /dev/null 2>&1
-
-if [ $? = "1" ]; then
- echo "Fcitx seems is not running"
- fcitx5
-else
- echo "Fcitx is running correctly."
-fi
diff --git a/misc/fcitx5/fcitx5.SlackBuild b/misc/fcitx5/fcitx5.SlackBuild
deleted file mode 100644
index 662f996168..0000000000
--- a/misc/fcitx5/fcitx5.SlackBuild
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/bash
-
-# Copyright 2022-2023 Wen-Wei Kao (ltlnx), Taichung, Taiwan
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=fcitx5
-VERSION=${VERSION:-5.1.8}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-${VERSION}_dict.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
- -DCMAKE_C_FLAGS="${SLKCFLAGS}" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} ..
- make
- make install/strip DESTDIR=$PKG
-cd ..
-
-
-# Use our own autostart script to autostart fcitx5
-install -m 755 $CWD/fcitx5-autostart $PKG/usr/bin/
-sed -i "s|Exec=/usr/bin/fcitx5|Exec=/usr/bin/fcitx5-autostart|" \
- $PKG/etc/xdg/autostart/org.fcitx.Fcitx5.desktop
-
-rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSES/* README* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/misc/fcitx5/fcitx5.info b/misc/fcitx5/fcitx5.info
deleted file mode 100644
index e185c82b2b..0000000000
--- a/misc/fcitx5/fcitx5.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="fcitx5"
-VERSION="5.1.8"
-HOMEPAGE="https://fcitx-im.org/wiki/Fcitx_5"
-DOWNLOAD="https://download.fcitx-im.org/fcitx5/fcitx5/fcitx5-5.1.8_dict.tar.xz"
-MD5SUM="f3cabadf80a3bdd252d37079bbdcecdf"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="fmt xcb-imdkit"
-MAINTAINER="ltlnx"
-EMAIL="ltlnx@disroot.org"
diff --git a/misc/fcitx5/slack-desc b/misc/fcitx5/slack-desc
deleted file mode 100644
index eaccae7994..0000000000
--- a/misc/fcitx5/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-fcitx5: fcitx5 (Input Method Framework)
-fcitx5:
-fcitx5: Fcitx is an input method framework with extension support. Currently
-fcitx5: it supports Linux and Unix systems like freebsd. It has three built-
-fcitx5: in Input Method Engine, Pinyin, QuWei and Table-based input methods.
-fcitx5: Fcitx tries to provide a native feeling under all desktop as well as
-fcitx5: a light weight core. You can easily customize it to fit your
-fcitx5: requirements.
-fcitx5:
-fcitx5: Homepage: https://fcitx-im.org/wiki/Fcitx_5
-fcitx5: