summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2022-02-15 17:59:17 +0100
committer Willy Sudiarto Raharjo2022-02-16 02:20:08 +0100
commita35a5507a5b2d2f3324867e69dadcf6574409011 (patch)
treec518fe4407de8af43554ebf7d7f0a4096c514950
parent4c8a39ffd6e8915278532b9bbc1044f4eedad00e (diff)
downloadslackbuilds-a35a5507a5b2d2f3324867e69dadcf6574409011.tar.gz
development/pyenchant: Fix 15.0 build, add python3 support.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/pyenchant/pyenchant.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/development/pyenchant/pyenchant.SlackBuild b/development/pyenchant/pyenchant.SlackBuild
index 7cfbe80ffc..dba3f6aead 100644
--- a/development/pyenchant/pyenchant.SlackBuild
+++ b/development/pyenchant/pyenchant.SlackBuild
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -62,11 +59,16 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220215 bkw: our library is called libenchant-2.so, which setup.py
+# isn't expecting.
+sed -i '/find_library/s,"enchant","enchant-2",' enchant/_enchant.py
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION