summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-02-06 09:28:37 +0100
committer Willy Sudiarto Raharjo2022-02-07 02:24:49 +0100
commit27294b1360718835d3c4febaf7818cbf7c3813eb (patch)
tree9d1211dc74efafb35557faff709294d65dff4a07
parentb748b2812dee68eb8951a57b4387fb0144329870 (diff)
downloadslackbuilds-27294b1360718835d3c4febaf7818cbf7c3813eb.tar.gz
python/yarl: Updated for version 1.6.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/yarl/yarl.SlackBuild12
-rw-r--r--python/yarl/yarl.info8
2 files changed, 12 insertions, 8 deletions
diff --git a/python/yarl/yarl.SlackBuild b/python/yarl/yarl.SlackBuild
index 8d8a4d4dba..f87dbf1ad7 100644
--- a/python/yarl/yarl.SlackBuild
+++ b/python/yarl/yarl.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/bash
+#!/bin/sh
# Slackware build script for yarl
-# Copyright 2019 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2019-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yarl
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,13 +78,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Workaround taken from Arch Linux PKGBUILD
+# https://github.com/archlinux/svntogit-community/blob/packages/python-yarl/trunk/PKGBUILD
+sed 's| .install-cython ||g' -i Makefile
+make cythonize
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.rst docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst requirements/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/yarl/yarl.info b/python/yarl/yarl.info
index 7fceb781e0..578c08fef5 100644
--- a/python/yarl/yarl.info
+++ b/python/yarl/yarl.info
@@ -1,10 +1,10 @@
PRGNAM="yarl"
-VERSION="1.3.0"
+VERSION="1.6.3"
HOMEPAGE="https://yarl.readthedocs.io/en/stable/"
-DOWNLOAD="https://github.com/aio-libs/yarl/archive/v1.3.0/yarl-1.3.0.tar.gz"
-MD5SUM="be1f160ce1711056aa54e1089a74a6e1"
+DOWNLOAD="https://github.com/aio-libs/yarl/archive/v1.6.3/yarl-1.6.3.tar.gz"
+MD5SUM="115325dfeec2efe9a507ea448617393a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-multidict"
+REQUIRES="python3-multidict typing-extensions"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"