summaryrefslogtreecommitdiffstats
path: root/system/webmin/webmin.SlackBuild
blob: da8e6f77adb152916ff0974c3625a074ecdd4695 (plain)
#!/bin/bash

# Slackware build script for Webmin http://www.webmin.com

# Copyright 2006-2019  David Somero (dsomero@hotmail.com)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=webmin
VERSION=${VERSION:-2.105}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

ARCH=noarch

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=${TMP}/package-${PRGNAM}
OUTPUT=${OUTPUT:-/tmp}

# Check if webmin is running - if so, the build will fail...
if [ -e /etc/webmin/miniserv.conf ]; then
  PIDFILE=$(grep "^pidfile=" /etc/webmin/miniserv.conf | sed -e 's/pidfile=//g')
  if [ -e $PIDFILE ]; then
    echo "Webmin is running or a stale pid file exists."
    echo "Stop webmin and/or remove $PIDFILE"
    exit 1
  fi
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

rm -f mount/{freebsd,openbsd,macos}-mounts*

( find . -name '*.cgi' ; find . -name '*.pl' ) | perl perlpath.pl /usr/bin/perl -

mkdir -p $PKG/usr/libexec/webmin $PKG/var/log/webmin \
  $PKG/etc/rc.d $PKG/etc/webmin

install -m 0644 $CWD/rc.webmin $PKG/etc/rc.d/rc.webmin

cp -rp * $PKG/usr/libexec/webmin
echo "slackware" > $PKG/usr/libexec/webmin/install-type
echo "/usr/libexec/webmin" > $PKG/usr/libexec/webmin/install-dir

config_dir=$PKG/etc/webmin
var_dir=$PKG/var/log/webmin
perl=/usr/bin/perl
autoos=1
port=10000
login=root
crypt="XXX"
host=$(hostname)
ssl=0
atboot=0
nostart=1
nochown=1
autothird=1
nouninstall=1
noperlpath=1
nopostinstall=1

export config_dir var_dir perl autoos port login crypt host ssl atboot \
 nostart nochown autothird nouninstall noperlpath nopostinstall

cd $PKG/usr/libexec/webmin
  ./setup.sh 2>&1
cd -

# Fixup the package files to use their real locations
sed -i -e 's:^pidfile=.*$:pidfile=/var/run/webmin.pid:' $PKG/etc/webmin/miniserv.conf
find $PKG -type f | xargs sed -i -e "s:$PKG::g"

# Remove some stuff we don't need
rm -rf $PKG/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1
rm -f $PKG/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1.tar.gz

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENCE* README.md $CWD/webmin.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

# Find config files and add the .new.
get_config_files() {
  for i in $(ls -1 $1); do
    if [ -d "$1/$i" ]; then
      get_config_files "$1/$i"
    else
      echo "preserve_perms $1/$i.new " | sed -e "s#$PKG/##g" \
        >> $PKG/install/doinst.sh
      mv "$1/$i" "$1/$i.new"
    fi
  done
}

# Finish the doinst.sh by adding the .new file handler.
if [ -e $PKG/etc ]; then
  get_config_files $PKG/etc
fi

rm -f $PKG/etc/webmin/{reload.new,.reload-init,restart-by-force-kill.new,.restart-by-force-kill-init,restart.new,.restart-init,start.new,.start-init,stop.new,.stop-init}
install -m 0755 $CWD/*.new $PKG/etc/webmin

# Fix a few ownership issues
chown -R root:root $PKG/etc $PKG/var

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE