summaryrefslogtreecommitdiffstats
path: root/system/man-pages-ja/man-pages-ja.SlackBuild
blob: 2bbb5ffcfdb2c603ebb9eb576f3e6060c91d37e5 (plain)
#!/bin/bash

# Slackware build script for man-pages-ja

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=man-pages-ja
VERSION=${VERSION:-20201015}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

ARCH=noarch

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# I'm almost certain this is correct, based on how other distros do it.
# The other possibility was "ja.UTF-8". A /usr/man/jp dir does exist on
# Slackware (containing cdparanoia's man pages), but it shouldn't.
MANLANG=ja

# this thing uses an interactive script with lots of prompts, not
# suited to automated builds. the patch just makes the script read
# from the environment instead of stdin, and gets rid of the 120 or
# so prompts for the sub-package conflicts (just taking the default).

patch -p1 < $CWD/noninteractive_install.diff
MANROOT=$PKG/usr/man/$MANLANG make config
make install

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README_SBo.txt
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}