summaryrefslogtreecommitdiffstats
path: root/system/fatrace/fatrace.SlackBuild
blob: da5374c384f88316bd005bb12fc457d4225fe820 (plain)
#!/bin/bash

# Slackware build script for fatrace

# Originally written by Leonardo Citrolo.
# Now maintained by B. Watson (urchlay@slackware.uk).

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20230509 bkw:
# - new maintainer.
# - relicense as WTFPL with permission from original author.
# - update for v0.17.0.
# - add RUNTESTS environment variable.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=fatrace
VERSION=${VERSION:-0.17.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

sed -i -e "/^CFLAGS/s,-O2,$SLKCFLAGS," \
       -e 's,share/man,man,' \
       -e 's,-Werror,,' \
       Makefile

make
strip $PRGNAM
make install DESTDIR=$PKG PREFIX=/usr
gzip $PKG/usr/man/man*/*

# This is disabled by default because it creates (and deletes) an
# /etc/test.txt (outside of $TMP).
if [ "${RUNTESTS:-no}" = "yes" ]; then
  # Tests assume wrong path (our /usr/bin/head is a symlink to /bin/head)
  sed -i 's,/usr/bin/,/bin/,' tests/fatrace
  sh tests/run
fi

PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
cp -a COPYING NEWS $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE