summaryrefslogtreecommitdiffstats
path: root/office/hunspell-id/hunspell-id.SlackBuild
blob: fbd5d99ff4c2f71e5e425c6023d4edba6d8debec (plain)
#!/bin/bash

# Slackware build script for hunspell-id

# Copyright 2017 Ali Ahmadi <idnux09@gmail.com>
# # All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Based on the Arch PKGBUILD

# 20220217 bkw: Modified by SlackBuilds.org, BUILD=2:
# - fix download URL.
# - merge hyphen-id with this build. they install files from the same
#   source archive, there's no reason to have separate builds.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=hunspell-id
VERSION=${VERSION:-2.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH="noarch"

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}


set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION

unzip $CWD/id-id.oxt '*.dic' info/long-description.txt

# Putting everything in proper place
mkdir -p $PKG/usr/share/{hunspell,hyphen}
install -m644 id_ID.* $PKG/usr/share/hunspell
install -m644 hyph_id_ID.dic $PKG/usr/share/hyphen

# myspell symlinks
install -dm755 $PKG/usr/share/myspell/dicts
pushd $PKG/usr/share/myspell/dicts
  for file in $PKG/usr/share/hunspell/*; do
    ln -sv ../../hunspell/$(basename $file) .
  done
popd
ln -s ../../hyphen/hyph_id_ID.dic $PKG/usr/share/myspell/dicts

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
install -m644 info/long-description.txt $PKG/usr/doc/$PRGNAM-$VERSION/README.txt
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE