summaryrefslogtreecommitdiffstats
path: root/office/fop/fop.SlackBuild
blob: d7153b69479cca4a497a7e043a70bbde7bc7f817 (plain)
#!/bin/bash

# Slackware build script for fop

# Copyright 2015 Thorn Inurcide USA
# Copyright 2020, 2021, 2023 Lenard Spencer, Orlando, Florida, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220412 bkw: Modified by SlackBuilds.org, BUILD=2:
# - remove mention of jai and jai-imageio from README, since we no
#   longer have these in the repo.
# - use relative symlink for binary.

# 20220301 bkw: Modified by SlackBuilds.org: fix build on 15.0.
# The fop-2.6 SlackBuild downloaded 230 prebuilt .jar files during its
# build process. Since we're trusting prebuilt code anyway, and since
# we prefer not to do network access from a SlackBuild, I've made this
# a binary repack: this script no longer builds fop, it just packages
# the official binary release.
# Also updated for version 2.7, and made this a noarch package since
# there's no native code.
# The offo-hyphenation stuff had to change: we have to use the precompiled
# zip file, not the source. See:
# https://xmlgraphics.apache.org/fop/2.7/hyphenation.html

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=fop
VERSION=${VERSION:-2.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

ARCH=noarch

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG/opt/$PRGNAM-$VERSION $OUTPUT
cd $PKG/opt
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-bin.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+

PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
mv KEYS LICENSE NOTICE README $PKGDOC

mv $PRGNAM $PRGNAM.old
mv $PRGNAM.old/* .
rmdir $PRGNAM.old

# 20220305 bkw: don't need windows stuff
rm -f $PRGNAM.{bat,cmd}

# 20220305 bkw: OFFO hyphenation can't be distributed with FOP, due
# to licensing issues. Here it's a separate .jar file:
unzip -p $CWD/offo-hyphenation-compiled.zip \
  offo-hyphenation-compiled/fop-hyph.jar \
  > lib/fop-hyph.jar

# Symlink it all to /opt/fop so the .foprc won't need edited every update:
cd $PKG/opt
ln -s $PRGNAM-$VERSION $PRGNAM

mkdir -p $PKG/usr/bin
ln -s ../../opt/$PRGNAM-$VERSION/$PRGNAM $PKG/usr/bin/$PRGNAM

cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE