summaryrefslogtreecommitdiffstats
path: root/network/thttpd/thttpd.SlackBuild
blob: e8f412a54cd6a1e897994cb9e94c06000e281c2b (plain)
#!/bin/sh

# Slackware build script for thttpd

# Yth | Pont-en-Royans, France | yth@ythogtha.org
# Written by Antonio Hernández Blas <hba.nihilismus@gmail.com>

# Copyright (c) 2008-2011, Antonio Hernández Blas <hba.nihilismus@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are met:
# 1.- Redistributions of source code must retain the above copyright
#     notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=thttpd
VERSION=${VERSION:-2.29}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

# Set the directory to serve through HTTP
WEBDIR=${WEBDIR:-/var/www/$PRGNAM}

# Check for thttpd user account
if ! grep ^thttpd: /etc/passwd 2>&1 > /dev/null; then
  echo "  You must have a thttpd user/group to run this script."
  echo "    # groupadd -g 227 thttpd"
  echo "    # useradd -u 227 -g 227 -c \"User for thttpd\" -d / -s /bin/false thttpd"
  exit 1
fi

# Check for thttpd group
if ! grep ^thttpd: /etc/group 2>&1 > /dev/null; then
  echo "  You must have a thttpd group to run this script."
  echo "    # groupadd -g 227 thttpd"
  exit 1
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Apply some patches, from arch/gentoo:
for i in $CWD/patches/*.patch
do
  echo
  echo "Appling patch $i ..."
  cat $i | patch -p1 || exit 1
done
echo

# Fix CFLAGS detection
sed -i \
  -e 's/^CFLAGS =/CFLAGS +=/' \
  -e '/^STATICFLAG =/c STATICFLAG =' \
    Makefile* extras/Makefile* cgi-src/Makefile*

# Fix --build value detection in ./configure
libtoolize --force --copy --install

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --build=$ARCH-slackware-linux

# Fix 'DESTDIR'
sed -i \
  -e 's/$(DESTDIR)//g' \
  -e '/prefix =/ s/\/usr/$(DESTDIR)\/usr/' \
  -e '/MANDIR =/ s/\/usr\/man/$(DESTDIR)\/usr\/man/' \
  -e '/WEBDIR =/ s/$(prefix)\/www/$(DESTDIR)'$(echo $WEBDIR | sed 's/\//\\\//g')'/' \
    Makefile* extras/Makefile* cgi-src/Makefile*

# Change the group to 'thttpd', rather than 'www'
sed -i '/WEBGROUP =/ s/www/'$PRGNAM'/' Makefile* extras/Makefile* cgi-src/Makefile*

### Use the next line ONLY if you are going to build thttpd as a normal user.
### sed -i '/WEBGROUP =/ s/'$PRGNAM'/'$(/bin/id -ng)'/' Makefile* extras/Makefile* cgi-src/Makefile*

# Disable the use of bin as owner user and group.
sed -i 's/-o bin -g bin//' Makefile* extras/Makefile* cgi-src/Makefile*

# Create required directories
mkdir -p $PKG/etc/rc.d $PKG/usr/man/man1 $PKG/etc/logrotate.d \
  $PKG/var/log/$PRGNAM $PKG/var/run/$PRGNAM
chown $PRGNAM:$PRGNAM $PKG/var/log/$PRGNAM $PKG/var/run/$PRGNAM

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# Install default html file.
install -m 644 index.html $PKG/$WEBDIR
# Install default configuration file
install -m 644 $CWD/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
# Edit the configuration file to reflect the value of $WEBDIR
sed -i 's/^dir=.*/dir='$(echo $WEBDIR | sed 's/\//\\\//g')'/' $PKG/etc/$PRGNAM.conf.new
# Install runtime script
install -m 755 $CWD/rc.$PRGNAM $PKG/etc/rc.d/rc.$PRGNAM.new
# Install lograte file
install -m 644 $CWD/$PRGNAM.logrotate $PKG/etc/logrotate.d/$PRGNAM.new

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a FILES INSTALL README TODO scripts $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
echo "preserve_perms etc/rc.d/rc.$PRGNAM.new" >> $PKG/install/doinst.sh
echo "config etc/$PRGNAM.conf.new" >> $PKG/install/doinst.sh
echo "config etc/logrotate.d/$PRGNAM.new" >> $PKG/install/doinst.sh

# Fix permissions.
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;

# To avoid a conflict with httpd(apache) package.
mv $PKG/usr/man/man1/htpasswd.1.gz $PKG/usr/man/man1/htpasswd-$PRGNAM.1.gz
mv $PKG/usr/sbin/htpasswd $PKG/usr/sbin/htpasswd-$PRGNAM

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}