summaryrefslogtreecommitdiffstats
path: root/network/slack/slack.SlackBuild
blob: 90c0e97523a40683c3e72f4338d05dfb8855c731 (plain)
#!/bin/bash

# Slackware build script for slack

# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
# Harald Achitz | Stockholm/Sweden | harald.achitz@gmail.com
# Pedro R.M. Júnior | Campinas, SP, Brazil | pedrormjunior@gmail.com
# Ruari Oedegaard | Oslo, Norway | sbo@ruari.com

# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version, with the following exception:
# the text of the GPL license may be omitted.

# This program is distributed in the hope that it will be useful, but
# without any warranty; without even the implied warranty of
# merchantability or fitness for a particular purpose. Compiling,
# interpreting, executing or merely reading the text of the program
# may result in lapses of consciousness and/or very being, up to and
# including the end of all existence and the Universe as we know it.
# See the GNU General Public License for more details.

# You may have received a copy of the GNU General Public License along
# with this program (most likely, a file named COPYING).  If not, see
# <https://www.gnu.org/licenses/>.


cd $(dirname $0) ; CWD=$(pwd)

# A trick to find the latest slack package details, using snap meta data
# curl -sH Snap-Device-Series:\ 16 https://api.snapcraft.io/v2/snaps/info/slack | json_pp
PRGNAM=slack
VERSION=${VERSION:-4.37.101}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
SNAPREVISION=${SNAPREVISION:-142}
SNAPPKG=JUJH91Ved74jd4ZgJCpzMBtYbPOzTlsD_$SNAPREVISION.snap

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    x86_64) ARCH=x86_64 ;;
         *) echo "Package for $(uname -m) architecture is not available." ; exit 1 ;;
  esac
fi

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
unsquashfs -q -f -d . $CWD/$SNAPPKG usr/lib/slack usr/share/pixmaps/slack.png meta/gui/slack.desktop
mkdir -p usr/bin usr/share/applications
ln -s ../../usr/lib/slack/slack usr/bin/slack
sed 's,\${SNAP},,' meta/gui/slack.desktop > usr/share/applications/slack.desktop

chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

mv usr $PKG/

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
cp -a $PKG/usr/lib/slack/LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE