summaryrefslogtreecommitdiffstats
path: root/network/hiawatha/hiawatha.SlackBuild
blob: 98fb958899842ad1dce9cdd1b6a847ddfa8b589e (plain)
#!/bin/sh

# Slackware build script for hiawatha

# Copyright (c) 2009-2012, Antonio Hernández Blas <hba.nihilismus@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are met:
# 1.- Redistributions of source code must retain the above copyright
#     notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=hiawatha
VERSION=${VERSION:-9.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

mkdir -p build
cd build
  cmake \
    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_INSTALL_SYSCONFDIR=/etc \
    -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
    -DCMAKE_INSTALL_MANDIR=/usr/man \
    -DCONFIG_DIR=/etc/$PRGNAM \
    -DLOG_DIR=/var/log/$PRGNAM \
    -DPID_DIR=/var/run/$PRGNAM \
    -DWEBROOT_DIR=/srv/$PRGNAM \
    -DWORK_DIR=/var/lib/$PRGNAM \
    -DCMAKE_BUILD_TYPE=Release ..
  make
  make install DESTDIR=$PKG
cd ..

# Correct the userid and groupid(s) the server will change to:
sed -i 's/^#ServerId/ServerId/' $PKG/etc/$PRGNAM/$PRGNAM.conf
sed -i "s/www-data/$PRGNAM:$PRGNAM/" $PKG/etc/$PRGNAM/$PRGNAM.conf

# Add the configuration needed by the PHP-FastCGI utility to make it
# Just Work(tm) in Slackware(r) Linux(r) :)

mkdir -p $PKG/var/run/$PRGNAM
echo "Server = /usr/bin/php-cgi ; 1 ; /var/run/$PRGNAM/php-fcgi.sock ; php-fcgi:php-fcgi ; /etc/httpd/php.ini" >> \
  $PKG/etc/$PRGNAM/php-fcgi.conf

sed -i "s:/var/run/php-fcgi.pid/:/var/run/$PRGNAM/php-fcgi.pid:" \
  $PKG/etc/$PRGNAM/php-fcgi.conf

sed -i "s_ConnectTo = 127.0.0.1:2005_ConnectTo = /var/run/$PRGNAM/php-fcgi.sock_" \
  $PKG/etc/$PRGNAM/$PRGNAM.conf

# Set the correct permissions for pid/socket directory.
chown hiawatha:php-fcgi $PKG/var/run/$PRGNAM
chmod 770 $PKG/var/run/$PRGNAM

# Install init scipts
mkdir -p $PKG/etc/rc.d/
install -m 0644 $CWD/rc.$PRGNAM $PKG/etc/rc.d/rc.$PRGNAM
install -m 0644 $CWD/rc.php-fcgi $PKG/etc/rc.d/rc.php-fcgi

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/extra
cp -a ChangeLog LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# Add some extra scripts from upstream
for script in mkcert newroot
do
  cat extra/$script > $PKG/usr/doc/$PRGNAM-$VERSION/extra/$script
done

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

# Add .new extension to all configuration files.
for file in $(find $PKG/etc -type f)
do
  mv $file $file.new
done

# Add *.new files into doinst.sh
for file in $(find $PKG/etc/rc.d $PKG/etc/$PRGNAM -type f -name "*.new")
do
  echo preserve_perms $(echo $file | sed "s:$PKG/::") >> $PKG/install/doinst.sh
done

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}