summaryrefslogtreecommitdiffstats
path: root/multimedia/smplayer/smplayer.SlackBuild
blob: 2707683afffde935fe1e01a3d7ec973476f1d05c (plain)
#!/bin/sh

# Slackware build script for SMPlayer

# Copyright 2011-2015  Fridrich von Stauffenberg <cancellor2@gmail.com>
# Copyright 2019 Andrzej Telszewski, Szczecin
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=smplayer
VERSION=${VERSION:-19.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

THEMES=${THEMES:-18.6.0}
SKINS=${SKINS:-15.2.0}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

# Fix man page path.
sed -i "s/share\/man/man/g" Makefile

if [ ${USE_QT5:-no} = yes ]; then
  QMAKE=qmake-qt5
  LRELEASE=lrelease-qt5
else
  QMAKE=qmake
  LRELEASE=lrelease
fi

make \
  QMAKE=$QMAKE \
  LRELEASE=$LRELEASE \
  PREFIX=/usr \
  DOC_PATH="\\\"/usr/doc/$PRGNAM-$VERSION/\\\"" \
  QMAKE_OPTS="QMAKE_CXXFLAGS=\"$SLKCFLAGS\""

make install \
  PREFIX=/usr \
  DOC_PATH=/usr/doc/$PRGNAM-$VERSION \
  DESTDIR=$PKG

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt Changelog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

cd $TMP
rm -rf $PRGNAM-themes-$THEMES
tar xvf $CWD/$PRGNAM-themes-$THEMES.tar.bz2
cd $PRGNAM-themes-$THEMES
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

if [ ${USE_QT5:-no} = yes ]; then
  sed -i "s/rcc -binary/rcc-qt5 -binary/g" themes/Makefile
fi

make
make install PREFIX=/usr DESTDIR=$PKG

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/themes
cp -a *.txt Changelog $PKG/usr/doc/$PRGNAM-$VERSION/themes

cd $TMP
rm -rf $PRGNAM-skins-$SKINS
tar xvf $CWD/$PRGNAM-skins-$SKINS.tar.bz2
cd $PRGNAM-skins-$SKINS
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

if [ ${USE_QT5:-no} = yes ]; then
  sed -i "s/rcc -binary/rcc-qt5 -binary/g" themes/Makefile
fi

make
make install PREFIX=/usr DESTDIR=$PKG

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/skins
cp -a *.txt Changelog $PKG/usr/doc/$PRGNAM-$VERSION/skins

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}